Admob does not show up on solar2D project

Hello everyone, I’m a newbie.
I am developing my game project, however when I integrated admob into my project, admob was unable to show banner ad và interstitial ad.
I receive the following warnings:
WARNING: The ‘ads’ provider (admob) is not available on the simulator
WARNING: The ‘ads’ library is not available on this platform.

I appreciate all the help!

Just as the warning says: You can’t show ads in the simulator. Have you tested on a real device?

Yes, I tried it on real device but admob still doesn’t work.

We would need the log messages from the Admod events. Could be ads are not being loaded

Have you completed every step of Admob setup through Google’s interface? I guess there was some kind of confirmation / validation step at the end which needs to be done before it starts loading ads.

Yes, I’ve done that, I even experimented with the test ID banner provided by google, but everything still doesn’t work

OK, so that would be a good time to share which platform you are facing this problem and a sample project with your build.settings so others can see where the problem is. You can share files easily using the Upload button, 7th one in the reply window.

1 Like

This is my build.settings, it worked
build.settings (1.4 KB)