Android 64-bit Local Webviews Don't Load

When making 64-bit Android builds (tested using 3540 and 3545), trying to use a webview to display a local html file fails:

Webpage not available The webpage at content://PACKAGE/assets/FILENAME.html could not be loaded because: net::ERR\_FILE\_NOT\_FOUND

(where “PACKAGE” is the package identifier for my app and “FILENAME” is the name of the html file)

My html file is in the root directory of my project, though I tried moving it to a subdirectory and got the same result.

Also, I have usesPermissions = { “android.permission.INTERNET” } in my build.settings, even though it should not be necessary in this case. (I also tried removing it but it did not change the result.)

Note that REMOTE content DOES display (as in Corona’s webview sample that loads the public Corona website). It is only LOCAL content that does not.

There is one other topic about this issue from last week:

but no one has responded.

Does anyone know of any workarounds? Now, as of November 1, Google Play requires app updates target Android 9 (API level 28). And the only versions of Corona that support that level are the ones that produce 64-bit builds…

I have exactly the same problem, but no solution I’m afraid. :frowning:

Can anyone from Corona help?

What happens if you try and copy the file to system.DocumentsDirectory?


We’re working on the issue.

This should be fixed in next daily build, coming up soon.

Sounds good. Thanks!

Please try 2019.3549

Initial tests look good. Thanks so much for taking care of this!