Android build execution failed

Hello, trying to build for Android using the latest build, 2023.3695 (2023.8.22) but getting this error"

Execution failed for task ‘:App:mergeReleaseResources’.
17:02:08.625 > C:\Users\jsjst\AppData\Local\Temp\Corona Labs\CLtmpa20648\template\app\build\generated\corona_icons\mipmap-hdpi\desktop.ini: Error: The file name must end with .xml or .png

But there is no folder called CLtmpa20648 in the Temp\Corona Labs folder…

Those type of directories are created during build process, but the issue is desktop.ini. These Windows files are hidden, and I wonder if your project has one as it would be copying that to the resources.

You can try to find it and delete it as I don’t think you would need it in that directory, or you can try excluding it in the build.settings file.

1 Like

Yea, windows created some hidden files and android sdk doesn’t like it. If ignore setting won’t help you can do following:

Basically the advice is:

  1. Open the registry editor ( Start —> Run —> regedit )
  2. Locate or add the following DWORD key: HKEY_LOCAL_MACHINE —> SOFTWARE —> Microsoft —> Windows —> CurrentVersion —> Policies —> Explorer —> “UseDesktopIniCache”
  3. Modify that key so that it’s Value is 0 (zero)

Also you would delete existing files manually.

Thank you. Managed to find the desktop.ini file and deleted it. Juts had to turn on file visibility in Windows 10.

I suspect I have the same problem with my app. When trying to compile (using 2023.3693 and Windows 10) I get the following message,

10:00:18.352 * What went wrong:
10:00:18.352 Could not determine the dependencies of task ‘:App:lintVitalReportRelease’.
10:00:18.352 > Failed to find target with hash string ‘android-33’ in: C:\Windows\Temp\Corona Labs\sdk

When I try to open C:\Windows\Temp in my explorer it just won’t open. Can anybody help me out on this?