App Not Correctly Configured to Use Google Play Game Services

I’m trying to implement google play game services for my game but the log-in keeps failing.


    This is usually caused by one of these reasons:
    (1) Your package name and certificate fingerprint do not match
         the client ID you registered in Developer Console.
    (2) Your App ID was incorrectly entered.
    (3) Your game settings have not been published and you are
         trying to log in with an account that is not listed as
         a test account.

     To help you debug, here is the information about this app
     Package name         :   
     Cert SHA1 fingerprint:
     App ID from manifest : My App ID

     Check that the above information matches your setup in
     Developer Console. Also, check that you're logging in with the
     right account (it should be listed in the Testers section if
     your project is not yet published)


    android =
		usesPermissions =
		googlePlayGamesAppId = "App ID",

plugins =
		["plugin.gpgs.v2"] =
            publisherId = "com.coronalabs",
            supportedPlatforms = { android=true }


license =


        google =


            key = "license key",

            policy = "serverManaged"




local globalData = require( "globalData" )

local json = require( "json" )

globalData.gpgs = nil

globalData.gameCenter = nil

local platform = system.getInfo( "platform" )

local env = system.getInfo( "environment" )

if ( platform == "android" and env ~= "simulator" ) then

   globalData.gpgs = require( "plugin.gpgs.v2" )


local function gpgsInitListener( event )


      if not event.isError then

          if ( == "login" ) then  -- Successful login event

              print( json.prettify(event) )



        display.newText(layers.content, "error", centerX, centerY, "OpenSans-Regular.ttf", 18)




   -- Apple Game Center initialization/login listener

   local function gcInitListener( event )


      if then  -- Successful login event

          print( json.prettify(event) )




   if ( globalData.gpgs ) then 

      -- Initialize Google Play Games Services

      globalData.gpgs.login( { userInitiated=true, listener=gpgsInitListener } )


   elseif ( globalData.gameCenter ) then 

      -- Initialize Apple Game Center

      globalData.gameCenter.init( "gamecenter", gcInitListener )


The license key is copy pasted from the Google Play console, app ID as well and it matches the ID in the log, SHA1 certificate is also correct, app is published for alpha testing, Google play services are published. What could possibly be the problem?

Also what do they mean by client ID? Do they mean the OAuth2 Client ID?

Okay they work now I solved it. The SHA1 certificate in logcat was different than the one I obtained using keytool -list -keystore. I’d still like to know the reason they’re different if anyone knows. I got both certificates of my private key and debug key and both were not the same as the correct one shown in logcat. Does anyone know the reason for this?

Hey @yazan21, how did you fix this problem?
I’m having exactly the same problem that you described: everything is ok, appID, fingerprint, package, etc. App in production, But the message in logcat is: APP NOT CORRECTLY CONFIGURED TO USE GOOGLE PLAY GAME SERVICES

I’ve tried using sha1 that logcat mention and also my own sha1 of my keystore. Same results.

Hey @tranthor sorry for the late reply, does it work now?

I just noticed your original question and I thought I had responded. I don’t know your particular situation but in my case when this happens it is because I had a typo on the alias or the command lines somewhere. In certain circumstances, the command line tools will return a random hash value when you make a typo.

1 Like

I’m having sync problems for my game and Google play Games and I need help