Applovin plugin - No ads available

For the past couple weeks Applovin ads don’t show because it says “No ads available”. Does the plugin need updated or is there another issue?

The plugin inits fine. Here are events:
isError = false,
name = “adsRequest”,
phase = “init”,
provider = “applovin”

isError = true,
name = “adsRequest”,
phase = “failed”,
provider = “applovin”,
response = “No ads available (Error code 204)”,
type = “interstitial”

plugin.applovin: 2.0.4 (SDK: 4.2.1)

iOS or Android?
What region are you trying to get ads for?

The issue is with iOS but I have not tried it for android. I live in the US so I assume the region would be north america.

I just tested on Android and I have the same issue.

Let me try it with my keys.

Thanks for testing … I will be curious if you have same issue.

Long day but finally got to this, and I get ads.

I am using the legacy AppLovin plugin (link below) … is that what you tried?

Yes, that is what I tried. On an Android device from the USA.

I know my code is good because the last release worked fine so it must be an issue on the Applovin side.

Who maintains the Applovin plugin?

I emailed AppLovin and they said it does not look like an issue on their end.

I think the source code is on github so anybody can make changes to it. It is not an official Applovin plugin. Did they tell you what the error is?

It looks like the issue is with the age restriction setting. When I remove it the ads load but when I have it in I get the message “No ads available (Error code 204)”. So I guess the plugin needs to be fixed.

– Set age restriction
applovin.setIsAgeRestrictedUser( true )

I was told by support at applovin that when the applovin.setIsAgeRestrictedUser is set too true that they don’t serve ads so I am not sure why anyone would use the flag. I was under the understanding that when it is set too true that they would serve age appropriate ads. The documentation needs to updated.

1 Like