Appodeal plugin not build

Appodeal plugin not build on iOS:

ld: warning: object file (/Users/17studio/Desktop/Draw Rider — 9.7.2.app/.build/plugin.appodeal.base/StackProductPresentation.framework/StackProductPresentation(SKAdNetworkParameters.o)) was built for newer iOS version (9.0) than being linked (8.0) ld: warning: object file (/Users/17studio/Desktop/Draw Rider — 9.7.2.app/.build/plugin.appodeal.base/StackProductPresentation.framework/StackProductPresentation(STKAdImpression.o)) was built for newer iOS version (9.0) than being linked (8.0) ld: warning: object file (/Users/17studio/Desktop/Draw Rider — 9.7.2.app/.build/plugin.appodeal.base/StackProductPresentation.framework/StackProductPresentation(SafariPresenter.o)) was built for newer iOS version (9.0) than being linked (8.0) ld: warning: object file (/Users/17studio/Desktop/Draw Rider — 9.7.2.app/.build/plugin.appodeal.base/StackProductPresentation.framework/StackProductPresentation(PrepareOperation.o)) was built for newer iOS version (9.0) than being linked (8.0) ld: warning: object file (/Users/17studio/Desktop/Draw Rider — 9.7.2.app/.build/plugin.appodeal.base/StackProductPresentation.framework/StackProductPresentation(StoreKitPresenter.o)) was built for newer iOS version (9.0) than being linked (8.0) ld: warning: object file (/Users/17studio/Desktop/Draw Rider — 9.7.2.app/.build/plugin.appodeal.base/StackProductPresentation.framework/StackProductPresentation(ValidateOperation.o)) was built for newer iOS version (9.0) than being linked (8.0) ld: warning: object file (/Users/17studio/Desktop/Draw Rider — 9.7.2.app/.build/plugin.appodeal.base/StackProductPresentation.framework/StackProductPresentation(StoreKitParameters.o)) was built for newer iOS version (9.0) than being linked (8.0) ld: warning: object file (/Users/17studio/Desktop/Draw Rider — 9.7.2.app/.build/plugin.appodeal.base/StackProductPresentation.framework/StackProductPresentation(CompleteOperatation.o)) was built for newer iOS version (9.0) than being linked (8.0) ld: warning: object file (/Users/17studio/Desktop/Draw Rider — 9.7.2.app/.build/plugin.appodeal.base/StackIABAssets.framework/StackIABAssets(STKIABLabelView.o)) was built for newer iOS version (9.0) than being linked (8.0) ld: warning: object file (/Users/17studio/Desktop/Draw Rider — 9.7.2.app/.build/plugin.appodeal.base/StackOpenMeasure.framework/StackOpenMeasure(STKMeasureBuilder.o)) was built for newer iOS version (9.0) than being linked (8.0) ld: warning: object file (/Users/17studio/Desktop/Draw Rider — 9.7.2.app/.build/plugin.appodeal.base/StackOpenMeasure.framework/StackOpenMeasure(STKMeasureEngine.o)) was built for newer iOS version (9.0) than being linked (8.0) ld: warning: object file (/Users/17studio/Desktop/Draw Rider — 9.7.2.app/.build/plugin.appodeal.base/StackIABAssets.framework/StackIABAssets(STKIABDrawing.o)) was built for newer iOS version (9.0) than being linked (8.0) ld: warning: object file (/Users/17studio/Desktop/Draw Rider — 9.7.2.app/.build/plugin.appodeal.base/StackProductPresentation.framework/StackProductPresentation(ProductParameters.o)) was built for newer iOS version (9.0) than being linked (8.0) ld: warning: object file (/Users/17studio/Desktop/Draw Rider — 9.7.2.app/.build/plugin.appodeal.base/StackProductPresentation.framework/StackProductPresentation(NetworkSession.o)) was built for newer iOS version (9.0) than being linked (8.0) ld: warning: object file (/Users/17studio/Desktop/Draw Rider — 9.7.2.app/.build/plugin.appodeal.base/StackProductPresentation.framework/StackProductPresentation(SafariParameters.o)) was built for newer iOS version (9.0) than being linked (8.0) ld: warning: object file (/Users/17studio/Desktop/Draw Rider — 9.7.2.app/.build/plugin.appodeal.base/StackProductPresentation.framework/StackProductPresentation(ExternalParameters.o)) was built for newer iOS version (9.0) than being linked (8.0) ld: warning: Could not find or use auto-linked library 'swiftFileProvider' ld: warning: Could not find or use auto-linked library 'swiftDataDetection' ld: warning: Could not find or use auto-linked library 'swift_Concurrency' ld: warning: Could not find or use auto-linked library 'swiftCompatibilityConcurrency' ld: warning: Could not find or use auto-linked framework 'AVFAudio' ld: warning: Could not find or use auto-linked framework 'DataDetection' Undefined symbols for architecture armv7:   "_OBJC_CLASS_$_SKAdImpression", referenced from:       objc-class-ref in MyTargetSDK(MTRGSkadParser.o)       objc-class-ref in AppLovinSDK(ALStoreKitService.o)       objc-class-ref in YandexMobileAds(YMASKAdImpressionFactory.o)       objc-class-ref in AdColony(ADCAdSession.o)       objc-class-ref in FBAudienceNetwork(FBAdSKAdNetworkManager.m.o)      (maybe you meant: _OBJC_CLASS_$_SKAdImpressionProxy)   "_SKStoreProductParameterCustomProductPageIdentifier", referenced from:       +[FBAdSKAdNetworkManager shouldCreateSkAdImpression:] in FBAudienceNetwork(FBAdSKAdNetworkManager.m.o)       +[FBAdSKAdNetworkManager skAdNetworkParamsFromDict:vt:] in FBAudienceNetwork(FBAdSKAdNetworkManager.m.o)   "__swift_FORCE_LOAD_$_swiftCompatibilityConcurrency", referenced from:       __swift_FORCE_LOAD_$_swiftCompatibilityConcurrency_$_FBAudienceNetwork in FBAudienceNetwork(FBAudienceNetwork.o)       __swift_FORCE_LOAD_$_swiftCompatibilityConcurrency_$_APDMyTargetAdapter in libAPDMyTargetAdapter.a(MyTargetVideoAdapter.o)       __swift_FORCE_LOAD_$_swiftCompatibilityConcurrency_$_APDMyTargetAdapter in libAPDMyTargetAdapter.a(MyTargetNativeAdRenderer.o)       __swift_FORCE_LOAD_$_swiftCompatibilityConcurrency_$_APDMyTargetAdapter in libAPDMyTargetAdapter.a(MyTargetAdapter.o)       __swift_FORCE_LOAD_$_swiftCompatibilityConcurrency_$_APDMyTargetAdapter in libAPDMyTargetAdapter.a(MyTargetBannerAdapter.o)       __swift_FORCE_LOAD_$_swiftCompatibilityConcurrency_$_APDMyTargetAdapter in libAPDMyTargetAdapter.a(MyTargetInterstitialAdAdapter.o)       __swift_FORCE_LOAD_$_swiftCompatibilityConcurrency_$_APDMyTargetAdapter in libAPDMyTargetAdapter.a(MyTargetFactory.o)       ...      (maybe you meant: __swift_FORCE_LOAD_$_swiftCompatibilityConcurrency_$_APDVungleAdapter, __swift_FORCE_LOAD_$_swiftCompatibilityConcurrency_$_APDFacebookAudienceAdapter , __swift_FORCE_LOAD_$_swiftCompatibilityConcurrency_$_FBAudienceNetwork , __swift_FORCE_LOAD_$_swiftCompatibilityConcurrency_$_APDIronSourceAdapter , __swift_FORCE_LOAD_$_swiftCompatibilityConcurrency_$_APDMyTargetAdapter , __swift_FORCE_LOAD_$_swiftCompatibilityConcurrency_$_APDGoogleAdMobAdapter , __swift_FORCE_LOAD_$_swiftCompatibilityConcurrency_$_APDAppLovinAdapter )   "__swift_FORCE_LOAD_$_swiftDataDetection", referenced from:       __swift_FORCE_LOAD_$_swiftDataDetection_$_CriteoPublisherSdk in CriteoPublisherSdk(SKAdNetworkInfo.o)       __swift_FORCE_LOAD_$_swiftDataDetection_$_FBAudienceNetwork in FBAudienceNetwork(FBAudienceNetwork.o)       __swift_FORCE_LOAD_$_swiftDataDetection_$_APDMyTargetAdapter in libAPDMyTargetAdapter.a(MyTargetVideoAdapter.o)       __swift_FORCE_LOAD_$_swiftDataDetection_$_APDMyTargetAdapter in libAPDMyTargetAdapter.a(MyTargetNativeAdRenderer.o)       __swift_FORCE_LOAD_$_swiftDataDetection_$_APDMyTargetAdapter in libAPDMyTargetAdapter.a(MyTargetAdapter.o)       __swift_FORCE_LOAD_$_swiftDataDetection_$_APDMyTargetAdapter in libAPDMyTargetAdapter.a(MyTargetBannerAdapter.o)       __swift_FORCE_LOAD_$_swiftDataDetection_$_APDMyTargetAdapter in libAPDMyTargetAdapter.a(MyTargetInterstitialAdAdapter.o)       ...      (maybe you meant: __swift_FORCE_LOAD_$_swiftDataDetection_$_APDFacebookAudienceAdapter, __swift_FORCE_LOAD_$_swiftDataDetection_$_APDBidMachineAdapter , __swift_FORCE_LOAD_$_swiftDataDetection_$_APDVungleAdapter , __swift_FORCE_LOAD_$_swiftDataDetection_$_APDIronSourceAdapter , __swift_FORCE_LOAD_$_swiftDataDetection_$_APDYandexAdapter , __swift_FORCE_LOAD_$_swiftDataDetection_$_APDAppLovinAdapter , __swift_FORCE_LOAD_$_swiftDataDetection_$_APDUnityAdapter , __swift_FORCE_LOAD_$_swiftDataDetection_$_APDAdColonyAdapter , __swift_FORCE_LOAD_$_swiftDataDetection_$_CriteoPublisherSdk , __swift_FORCE_LOAD_$_swiftDataDetection_$_APDGoogleAdMobAdapter , __swift_FORCE_LOAD_$_swiftDataDetection_$_APDOguryAdapter , __swift_FORCE_LOAD_$_swiftDataDetection_$_FBAudienceNetwork , __swift_FORCE_LOAD_$_swiftDataDetection_$_StackProductPresentation , __swift_FORCE_LOAD_$_swiftDataDetection_$_APDMyTargetAdapter )   "__swift_FORCE_LOAD_$_swiftFileProvider", referenced from:       __swift_FORCE_LOAD_$_swiftFileProvider_$_CriteoPublisherSdk in CriteoPublisherSdk(SKAdNetworkInfo.o)       __swift_FORCE_LOAD_$_swiftFileProvider_$_FBAudienceNetwork in FBAudienceNetwork(FBAudienceNetwork.o)       __swift_FORCE_LOAD_$_swiftFileProvider_$_APDMyTargetAdapter in libAPDMyTargetAdapter.a(MyTargetVideoAdapter.o)       __swift_FORCE_LOAD_$_swiftFileProvider_$_APDMyTargetAdapter in libAPDMyTargetAdapter.a(MyTargetNativeAdRenderer.o)       __swift_FORCE_LOAD_$_swiftFileProvider_$_APDMyTargetAdapter in libAPDMyTargetAdapter.a(MyTargetAdapter.o)       __swift_FORCE_LOAD_$_swiftFileProvider_$_APDMyTargetAdapter in libAPDMyTargetAdapter.a(MyTargetBannerAdapter.o)       __swift_FORCE_LOAD_$_swiftFileProvider_$_APDMyTargetAdapter in libAPDMyTargetAdapter.a(MyTargetInterstitialAdAdapter.o)       ...      (maybe you meant: __swift_FORCE_LOAD_$_swiftFileProvider_$_APDGoogleAdMobAdapter, __swift_FORCE_LOAD_$_swiftFileProvider_$_APDOguryAdapter , __swift_FORCE_LOAD_$_swiftFileProvider_$_APDIronSourceAdapter , __swift_FORCE_LOAD_$_swiftFileProvider_$_APDAppLovinAdapter , __swift_FORCE_LOAD_$_swiftFileProvider_$_APDUnityAdapter , __swift_FORCE_LOAD_$_swiftFileProvider_$_APDMyTargetAdapter , __swift_FORCE_LOAD_$_swiftFileProvider_$_CriteoPublisherSdk , __swift_FORCE_LOAD_$_swiftFileProvider_$_FBAudienceNetwork , __swift_FORCE_LOAD_$_swiftFileProvider_$_APDAdColonyAdapter , __swift_FORCE_LOAD_$_swiftFileProvider_$_StackProductPresentation , __swift_FORCE_LOAD_$_swiftFileProvider_$_APDVungleAdapter , __swift_FORCE_LOAD_$_swiftFileProvider_$_APDYandexAdapter , __swift_FORCE_LOAD_$_swiftFileProvider_$_APDFacebookAudienceAdapter , __swift_FORCE_LOAD_$_swiftFileProvider_$_APDBidMachineAdapter ) ld: symbol(s) not found for architecture armv7 clang: error: linker command failed with exit code 1 (use -v to see invocation)
Sep 15 20:00:58.511 BUILD ERROR: There was a problem linking the app.  Check the console for more information.
Sep 15 20:00:58.511 
Sep 15 20:00:58.738 iOS build failed (2) after 249 seconds
Sep 15 20:00:59.088 ERROR: Build Failed: There was a problem linking the app.  Check the console for more information.

plugins:

 -- Base
        ['plugin.appodeal.base'] = { publisherId = 'com.coronalabs' },
 
        -- All types
        ['plugin.appodeal.Bidmachine'] = { publisherId = 'com.coronalabs' },
        ['plugin.appodeal.GoogleAdMob'] = { publisherId = 'com.coronalabs' },
        ['plugin.appodeal.A4G'] = { publisherId = 'com.coronalabs' },
        ['plugin.appodeal.AppLovin'] = { publisherId = 'com.coronalabs' },
        ['plugin.appodeal.FacebookAudience'] = { publisherId = 'com.coronalabs' },
        ['plugin.appodeal.MyTarget'] = { publisherId = 'com.coronalabs' },
        ['plugin.appodeal.Smaato'] = { publisherId = 'com.coronalabs' },
        ['plugin.appodeal.StartApp'] = { publisherId = 'com.coronalabs' },
        ['plugin.appodeal.Unity'] = { publisherId = 'com.coronalabs' },
        ['plugin.appodeal.Yandex'] = { publisherId = 'com.coronalabs' },
 
        -- Banner
        ['plugin.appodeal.AmazonAds'] = { publisherId = 'com.coronalabs' },
 
        -- Interstitial
        ['plugin.appodeal.AdColony'] = { publisherId = 'com.coronalabs' },
        ['plugin.appodeal.AmazonAds'] = { publisherId = 'com.coronalabs' },
        ['plugin.appodeal.IronSource'] = { publisherId = 'com.coronalabs' },
        ['plugin.appodeal.Ogury'] = { publisherId = 'com.coronalabs' },
        ['plugin.appodeal.Vungle'] = { publisherId = 'com.coronalabs' },
 
        -- Rewarded Video
        ['plugin.appodeal.AdColony'] = { publisherId = 'com.coronalabs' },
        ['plugin.appodeal.IronSource'] = { publisherId = 'com.coronalabs' },
        ['plugin.appodeal.Ogury'] = { publisherId = 'com.coronalabs' },
        ['plugin.appodeal.Vungle'] = { publisherId = 'com.coronalabs' },

Problem is in the plugin from yandex. How to make it work?

Changing minOS seemed to fix build issues for me

iphone =
	{
		xcassets = "Images.xcassets",
		plist =
		{
			MinimumOSVersion = "10.0",