build error#1 corona sdk 2019 3509

since i moved to the new corona version , my corona dont build aany app;

the logs:

Do you have Android Studio installed by any chance? It seems like path for your user is getting messed up somehow. Like, your user seems to be simple ASCII string, but it doesn’t behave like that.

Please, try again using latest daily build

i tried it

but is the same…error

OK. Do you have android Studio installed?

Only time when I seen errors like this is when user had non-ascii symbols in their name or something similar. Also, for some reason, your username is getting shortened, even if it doesn’t have any non-ascii in it.

I insltaled android studio last year… But for now I haven’t it

Hi Vlad! I installed the last build , jdk version and the android tudio as you asked me! But i its give the same error!

Help me please! I’m lost -_-

what i must do?

OK. Lets do the following. In start menu find Corona Native. It’s a directory. From it copy Project Template/App somewhere (where you have your projects).

After which, open Android studio, and select “Open existing android studio project” and select <location you copied App to>/android.

Then try building it.

Failed again!

What about the gradle problem that come in the log output?I don’t understand it, but it’s cause the build fail!

Wait. Android studio build failed? Ok. Try selecting “grade” on the right panel, in the drop down select app - build and then double click “assemble”
Please share android studio build log which will appear in the bottom

Sorry I didn’t understand good!

I tried with corona!
But now I’m doing it with android studio!
It’s processing…I’ll tell something after that

the build fail in android studio too…the build output

Wow. Can you try creating new Android Studio (no Corona, just Android) project and compile it?

OK. Here is the thing: everything points out to that you have some NON-ASCII symbols in your user name. But from what I see from the build log, there aren’t any. It’s just latin “Kprogrammer”. This is extremely weird, and I can’t put my finger on why it is happening.

Is there any chance you got some non-latin letters in your user home directory? Like ö or ø or something like that? Or may be cyrillic letter or anything of this sort?

i tried to build a simple android studio apk, but i give the same error that come in corona log output…

I downgraded my android build grade to 3.2.1 and now it’s building android studio projects!

And now, what is the next step?

Hi Vlads! I have been trying…but nothing

I waiting for you! I so down with this problem :mellow:

its possible to change the corona manually to '

Please try latest daily build.