Build failure on my apps and sample apps (ERROR: unable to fetch build ID)


I’ve went to push out an update to one of my apps today and got blocked by the api 28 requirement of Google. The app built fine, just couldn’t be uploaded. So i then updated to the latest Corona SDK 2020.3567 and I am unable to build for Android. I just get the error at the end of this post. I get the same thing regardless what project i try with, my own and even the corona samples (tried physics->bridge and FrameAnimation). 

java -version looks ok based on what i’ve read in the forums, its the latest 1.8 jdk. 

java version “1.8.0_241”

Java™ SE Runtime Environment (build 1.8.0_241-b07)

Java HotSpot™ 64-Bit Server VM (build 25.241-b07, mixed mode)

I am able to build for iOS fine with the same version, as as mentioned the earlier corona sdk i was using (32 bit android) also built fine but could not be used as mentioned earlier.

I read about the server issues, however given that i can build for iOS, and could build earlier for android, im thinking that is not likely to be the issue here.

Corona Log Output trying to build the Physics->Bridge sample

6:15:56.153  jar signed.

16:15:56.153  Picked up JAVA_TOOL_OPTIONS: -Duser.language=en

16:18:35.181  Using custom build id from app bundle: 00000 (AppSettings.lua)


16:18:35.181  Using custom Build Id 00000

16:19:12.425  @ver > NUL

16:19:12.425  Exception in thread “DisconnectableInputStream source reader” org.gradle.api.UncheckedIOException: Access is denied

16:19:12.425  at org.gradle.internal.UncheckedException.throwAsUncheckedException(

16:19:12.425  at org.gradle.internal.UncheckedException.throwAsUncheckedException(

16:19:12.425  at org.gradle.util.DisconnectableInputStream$

16:19:12.425  at

16:19:12.425  Caused by: Access is denied

16:19:12.425  at Method)

16:19:12.425  at

16:19:12.425  at

16:19:12.425  at

16:19:12.425  at

16:19:12.425  at org.gradle.util.DisconnectableInputStream$

16:19:12.425  … 1 more

16:19:12.425  Error while fetching plugins

16:19:12.425  No build.settings plugins to download

16:19:12.425  ERROR: unable to fetch build ID:



16:19:12.425  FAILURE: Build failed with an exception.


16:19:12.425  * Where:

16:19:12.425  Build file ‘C:\Users\Craig\AppData\Local\Temp\Corona Labs\CLtmpa11568\template\app\build.gradle.kts’ line: 595


16:19:12.425  * What went wrong:

16:19:12.425  Error while fetching plugins


16:19:12.425  * Try:

16:19:12.425  Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.


16:19:12.425  * Get more help at


16:19:12.425  BUILD FAILED in 36s

16:19:12.425  Picked up JAVA_TOOL_OPTIONS: -Duser.language=en

16:19:12.521  Android build failed (1) after 37 seconds

Please advise, not sure what else to try from here.


Ah got the same issue starting today. Made several packages yesterday and everything was fine…

Having the recommended Java versions as well

Update: I uninstalled everything Java related and then reinstalled jdk-8u231-windows-i586.

It installed Java, JRE and the SDK all version 8.

Still the same error message!

Any update from official side would be highly appreciated!

Finally had a build work for me this morning without changing anything, so my issues must be related to the build server outages that have been occurring over the last few weeks.


I had the same error. I have installed the jdk-12.0.2_windows-x64_bin.exe

Some suggestion?

You need Java, JRE and the SDK all version 8. Try this first. Other than that most build errors are related to their server problems…

I thought there havent been server problems for weeks now.

It could be an unrelated issue but still transient issue.


It works for me now.

I removed the jdk-12.0.2_windows-x64_bin.exe that I installed previously and install jdk-8u241-windows-i586.