Building for iOS, Invalid signature problem.

Dear all, I am having problem uploading apps to Apple Store. I get the below error:

ERROR ITMS-90035: "Invalid Signature. A sealed resource is missing or invalid. The file at path [Atalar sözləri sözləri oyunu] is not properly signed. Make sure you have signed your application with a distribution certificate, not an ad hoc certificate or a development certificate. Verify that the code signing settings in Xcode are correct at the target level (which override any values at the project level). Additionally, make sure the bundle you are uploading was built using a Release target in Xcode, not a Simulator target. If you are certain your code signing settings are correct, choose "Clean All" in Xcode, delete the "build" directory in the Finder, and rebuild your release target. For more information, please consult"

Before the latest version (2019.3550) I was having two more errors which were related to xcode version mismatch. Then as per recommendation of @vlads, I downloaded previous version of xcode and Corona version 2019.3545 to be able to update games. However, I could not achieve good results. 

Today I upgraded Corona to the latest version and then downloaded xcode version 11.2.1. However, this time I got the error above. I previously had problem with provisioning profiles. Therefore, I did all the things I had done before to make it work. Unfortunately, no success so far. 

I also removed all the certificates, keys from Keychain, revoked all the certificates and provisioning files from the Developer center and did everything from the scratch as explained on this page:

I also tried uploading with altool but it also didn’t work. I don’t know what else I can and should try. Plus, I tried deleting the old 11.1 version of xcode from Downloads folder and trying again, no success. 

While writing this post I noticed that xcode seems uninstalled on App Store app. I am now installing it through App Store with the hope that maybe it will help. 

Anyone has such a problem? Anyone has an idea to what to do and how to solve the problem? 

Let us know if the Xcode reinstall fixes this. Our tests showed successful uploads with Xcode 11.2.1 and the latest daily build.


For the last few times Xcode does not install or update when trying inside App Store app. It takes more time than when downloading from page. At the end of waiting 3-4 hours for the download to finish, it says there was an error installing. I’ll try one more time today and write the result.

I also tried moving Xcode from Applications folder to Trash folder and also deleting Corona Simulator, emptying the Trash folder, restarting Mac and installing both of them. Corona Simulator icon doesn’t show up on Launchpad again, and the Transporter gave me the same error. No success  :unsure:  

Today I was able to install Xcode from App Store after deleting the previous Xcode. However, I got the same error from the Transporter. I will revoke all the certificates and create again to see if it helps. 

I deleted all the certificates from KeyChain too many times, revoked all the certificates, did everything from the scratch too many times but still get the same error from the Transporter. Please, help!  :unsure:

I found the solution. It was related to the name of the file/app - “Atalar sözləri”. Either it was because of the spaces or the unicode alphabets in the file name. While searching for a solution, I came across to this SO link:

Sharing here in case someone needs and searches in the future.

I’m glad you’ve solved it. Corona should work fine with projects containing UTF-8 characters. Sounds like Apple may have broken something. Thanks for sharing your results.