Cannot authorize CoronaBuilder


I’ve tried to authorize corona builder (3602) and it seems there’s an error with that:

2020-09-10 10:08:48.007 CoronaBuilder[91679:2956593] XMLRPC: connection: 25C59601-    D41A-40D4-BF22-ADCCBBF2C099, [] failed with the following error: The request timed out.
2020-09-10 10:08:48.007 CoronaBuilder[91679:2956593] ERROR: XMLRPC: The request timed out.
2020-09-10 10:08:48.079 CoronaBuilder[91679:2956593] WebServices: XMLRPC request failed

error: CoronaBuilder: Could not authorize this computer. Please check your Internet connection or your login/password.

Having the same problem…

Are you two still using Corona builds? If yes, then you need to migrate to Solar2D.

Migrating a few years old game is not soemthing we will do overnight. It’s not an option at the moment, and we need to update some libraries or the game will be taken down from the app stores.

The official word is that the build servers will operate until 15 October, but they are already in decline and you may experience issues with them. For now, you can try building again a bit later.

Personally, when I transitioned from Corona to Solar2D, I didn’t need to do anything. Things just worked out of the box. It was just like downloading a new update. I’m using the simulator only though, so native developers may have more issues to deal with.

yeah, i understand that for up to date or recent projects it’s not a big deal, but 3602 was released quite some time ago :wink:

We are having the same issue, we are no longer able to build because of the xmlrpc authorization calls. This started around the beginning of september 2020.

We tried upgrading to the latest version and it does not work for us out of the box. We were on a commercial enterprise license using c++ lua biz libraries.

Biggest issues were

  1. removal of armeabi_v7 .so files like
  2. deprectation of coronabuilder app_sign option

augmenting the latest build by manually adding the above so files and removing the app_sign call causes the app to crash after it builds

anyone have anything they can point to to help us migrate? or something we can do to fix the authorization on the old build?