Can't build for iOS. Some issue with simctl

Using Latest Build 3699. Mac OS Sonoma 14.0 (23A344), Xcode 15.0.1
This Solar2D build worked a week ago. Xcode had a short update and then I started getting the following error when trying to build for iOS:

Nov 18 07:58:54.677 ERROR: unexpected output from ‘simctl’. Cannot enumerate Xcode iOS Simulator types: {
“devices” : {
“” : [
“availabilityError” : “runtime profile not found using “System” match policy”,
“dataPath” : “/Users/adiraz/Library/Developer/CoreSimulator/Devices/737BE817-802C-4E36-B9A2-4F1E6061DF31/data”,
“dataPathSize” : 0,
“logPath” : “/Users/adiraz/Library/Logs/CoreSimulator/737BE817-802C-4E36-B9A2-4F1E6061DF31”,
“udid” : “737BE817-802C-4E36-B9A2-4F1E6061DF31”,
“isAvailable” : false,
“deviceTypeIdentifier” : “”,
“state” : “Shutdown”,
“name” : “Apple TV”
“availabilityError” : “runtime profile not found using “System” match policy”,
“dataPath” :

this is followed by a dozen other errors on other simulator profiles…
Any help appreciated.

Problem was resolved by removing in Xcode its iOS simulator and reinstalling it.

Problem solved by installing the correct Xcode version and it’s iOS simulator to avoid the mismatch popup when building on iOS.
Here is a usefull link that can help resolving this issue: