can't require file that's in a subfolder on android with latest version

when i make a build with 2019.3523, on android it crashes.

same code in mac, with older version (don’t know the version). it works flawless.

Changed anything to use require???

can’t i use require('folder.file") anymore?

how to require a file that’s in a subfolder on android now if that’s not a bug.

I know subfolder doesn’t really exist on android but this code always worked fine before.

First, thanks for reporting this. I’m going to move it to the Android 64-bit testing forum where our engineering team is keeping a closer watch on common issues. This is the first I’ve heard of this.

Can you produce a simple test case that fails and submit a URL with a link to the .zip file please?



I changed the name from “scripts.menuCreator” to  “scripts.menu_creator” just to sleep well (i doubt this was the problem but just in case).

after that I checked corona new builds and there was one posted yesterday (2019.3525). I installed, made another apk…worked flawless again.

so I can’t reproduce the bug anymore.

Filenames are case insensitive on Macs and PC’s and thus the simulator. Devices running Android or iOS are case sensitive. That’s a possibility.

Glad you got it solved.