Corona Live Server - Android 33 build 2023 3693

hi, not sure if its just for me, but with this new build whenever I am testing apps with live server they keep crashing during synchronization and going into restart loop. I could only see 1 error in debug logs which says. Is this a known issue or something to with my installation/device ?

My device is API 31, the build generates with target 33, but I would have thought it should run normally for older devices as apps themselves run fine just the live server is not working

java.lang.NoSuchMethodException: android.view.SurfaceControl$Transaction.deferTransactionUntil [class android.view.SurfaceControl, class android.view.SurfaceControl, long]
at java.lang.Class.getMethod(
at java.lang.Class.getMethod(
at android.view.ViewRootImpl.lambda$registerRtFrameCallback$0(
at android.view.ViewRootImpl$$ExternalSyntheticLambda4.onFrameDraw(Unknown Source:2)
at android.view.ThreadedRenderer.lambda$updateRootDisplayList$0(
at android.view.ThreadedRenderer$$ExternalSyntheticLambda0.onFrameDraw(Unknown Source:2)

Edit: 3695 has the same issue

1 Like

Is the live build work just fine when your App is still targeting platform 31?

Not sure if its related to Restrições para interfaces que não são SDK  |  Desenvolvedores Android  |  Android Developers

And what device you in use?


Yes it worked fine when it was targetting platform 31 I did that before updating for 33 due to google play. Device I tested it on was a POCO X3 pro and a samsung s21 FE, both are on android 11/12 and not 13.

I have also been unable to get live builds to run on any of our android devices with the latest Solar2D build.

Just stays on a black screen.

Is this something that’s being looked at or have people reported it outside of this forum? @vlads

Thanks. I’ll look into it.

Still not working…

This should be fixed now.

1 Like

Top man Vlad, will give it a test shortly. Which version will the fix be under ? As I still see only 3696 as latest git release

Live builds is technically a plugin(checking the box on build screen just includes it), ie does not need a new release

1 Like

I’m still having issues with it, it opens the app but keeps synchronizing and closing again and again in a loop, am I missing something ?