Crash on startup on Samsung A71

Build: 2023.3690, Samsung A71 5G, Model number: SM-A716U

I have one user who cannot run one app, and I cannot figure it out. It crashes before it gets to my code. I have no logs or anything other than a Google report:

com.ansca.corona.JavaToNativeShim. java.lang.UnsatisfiedLinkError

I cannot replicate it. I do not have a Samsung A71 to try, but tried running the app on Samsung’s Remote Lab. It runs fine on the A71 in their lab in Hanoi, but not on a device in their lab in India – but that is suspicious, I could not get any app to run on the device in the India lab.

I have done special builds for this user, slimming down to log to my Loggly account, and it never gets there. Whatever I try makes no difference.

Any ideas what to try?

I have a couple of Samsung phones. If you tell me the app, I can see if I can reproduce it.

The app is BrassUp!

It had several thousand installs last month, only the one person has the crash, according to Google.

The behavior is: splash screen for a second, then black screen.

I have tried a dozen different Samsung phones using Browser Stack, cannot reproduce it.

If the user is receptive have you tried send him helloworld?

I’ve had countless times when this happens.

1 Like

He is receptive, has been very cooperative so far. I sent him a different, simple app of mine to try, he has not responded yet. I agree, I should send him Hello World. When I next hear from him, I will send that.

Well, I tried it on my two Samsung devices. No issues. I gave you a nice review for what it is worth.

1 Like

Thank you. I still haven’t heard back from the user.

a very dumb solution is to add a text at the top of your app, and insert this line of code everywhere

. and so on

at least when the app starts and crashes you will know which line crashed it

I have debug statements all through it, but the app itself never starts. After the splash screen, then a black screen, my code never starts.

So now it seems to be fixed. I did these 3 steps:

  1. Hello World – just a text object and background color in main: worked
  2. Hello World objects at the top of the main.lua of my app, but the composer step going to my app’s first scene commented out: worked
  3. Added back the loading of my first scene with a 1 sec delay: worked

?? Not sure what made a difference. Maybe just changing the size put the app on a different memory boundary, something random like that? Maybe some hidden race condition, changing the timing helped? I had tried commenting out most of the setup code in my main.lua previously, didn’t help, so maybe lengthening the time into the first scene instead of shortening it. ??

1 Like