Does this still work?


I’ve now got local TCP working for my latest title, looking at online games with Photon.
However I can’t get the Basic Sample working from here: Solar2D Documentation — Plugins | Photon
With an error ERROR LoadBalancingClient: 2101 Game authentication failed (32738 Wrong game server used to create/join game)
Only reference I can see with this error was resolve in a JS update for JScript and Typescript implementations, and guessing they don’t update their module for the Solar2d engine any longer.

Does anyone currenly have this working? Or should I not spend further time trying?

Many thanks,


I tried it some months ago and it worked just fine.

I downloaded the SDKs (still Corona branded) from their website (you’ll need to login):

Yes I’ve followed this route too.
Would you do me a favour please and double check your findings?
It’s possible it’s changed quite recently.
If I’ve done something wrong I will definitely ascertain what it is as keen to use this functionality.
Many thanks!!

Connects to NameServer, then MasterServer then GameServer ok, then errors:

Reason I’m query is I get the same error attempting to create a room after connecting to RegionMaster EU.
So can’t get any further at the moment.

I ran my old test project quickly and it seems to encounter the error same message. It’s possible that something has changed over at Photon’s backend.

Maybe someone else knows what’s going on? Photon seems to also have a Discord channel for support. You could ask there as well.

1 Like

Thanks for double checking!
I’ve been on the Discord :smiley:
Apparently the workflow has changed and the photon.lib is now incorrect rather than the demo code.
I’ve had a tinker, if I comment out the client:onStateChange function and run a createRoom on a timer of around 1850ms i.e. after connection to the MasterServer but before the createLobby runs I get a create Room nil nil without an error so that seems to work.
I’ve provided this information to the person who responded on Discord and they are going to have a look tomorrow and let me know if they can provide an updated lib or maybe a workaround for the change in workflow.
Will post back when I have more info!

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.