Error code: 256 on Android compile Version 20.20.3596

Hello everyone,

I have experimenting some problems to compile a business App developed with solar 2D…

It compiles well for iOS but not for Android. Always returns the error 256.

As I read on the forums there are some problems with plugins, I have commented the android’s plugins on the build.settings file…the same result: error 256.

Seams, some plugins need to change a little bit the configuration. What about general plugins like UTF-8? They need any change?

In any case, my question is:
In this App I have commented all the plugins. Why it doesn’t compile for Android? I need to show it.

If it’s a rush, you can still compile with the Corona Labs version… Do you get the same error there?

Also, if you thing it’s UTF-8, there’s non-plugin solutions for that…

Hi PonyWolf, thanks for your response!

No, I can’t compile with the Corona Labs version… :frowning:

For iOS all woks perfect but on Android I always obtain the code “Error code: 256”! on Corona or Solar2D.

For these reason I ask to the forums… I don’t know how to solve it.

About the utf8. I love the GitHub project you send me. Thanks you! but I finally have adapted a function to helps me to parse the JSON file received and it works fine.

I’m going to continue trying a solution.

Beste Regards

I found this. Maybe it’s related.

I think @bgmadclown is right. Make sure you have JDK 8 installed, not the latest.

The version I have now is the (build 1.8.0_25-b17). I’m working on a Mac.

I will try to downgrade it.


The Error code: 256 issue for Android is also here:

Thanks for the information troylyndon but, I have eliminated all the plugins. I have copied a clean build settings from the sample codes without any plugin to eliminate these problem… So, my error 256, could not been generated for the plugins.

I have the same problem on 2 projects: I can’t compile for Android with or without plugins. I have to try downgrade JVM.

@jalemanyf the Error code: 256 occurs on all online builds, until @vlads fixes it.

The solution is to move to the offline builds, assuming you are running on Mac. If on Windows, you might want to check with vlad first, as both online and offline builds can run side-by-side only on Mac, for now.

As we’ve said, downgrading Java below v8 will not solve your problem. It’s unrelated as far as we know; and I remember reading something vlad said about v8 is what’s in use, too.

I’m running Version 8 Update 191 (build 1.8.0_191-b12) on Mac with no issues.

I have tried with the two last offline builds Solar2D 2020.3597 and 2020.3596… error 256

As it doesn’t works… I tried with online… error 256.

I have eliminated all the plugins… error 256.

For these reason I wrote to the forum. Nothing seems to work.

I’m using an iMac with Mac OS Catalina with the 2020.35.97 version and a Macbook Pro( with Catalina two ) with the other versions…


@jalemanyf Are you running on Windows or Mac? When you choose About Corona Simulator (before creating your build), what Version appears? I’m asking because when I have both the online and offline versions available side-by-side, I find myself still using the online version unless I exit and restart my ZeroBrane editor. But checking the Corona Simulator About version is the certain way to know for sure. I’m running on Mac with no problems with 2020.3597.

Sorry to hear about your issues. 3582/3583 should work now.
Java 8 is the best java to use with android.

Hi Vlads,

Yes!!! now works with the 3583 version.

Thanks for your interest :wink: