Error loading module 'gameNetwork' on some devices

On our devices app is work fine but some users get that error.

How we can fix it?


module gpgs.v2 / gameNetwork:

How do you know it is not loading? Do you have an example of the error?


We have a backend for tracking errors.

Also our users says what can’t run app.

Builded by Corona v2019.3521


error loading module ‘gameNetwork’ from file ‘/data/app/ru.gmsoft.magazines.skanword_krepost-1/lib/arm64/’:


stack traceback: dlopen failed: library “” not found at error (External Function)

at (Unknown Function) (?:0)

at (Unknown Function) ((tail call))

at gotoScene (?:0)

at ? (?:0)

at (Unknown Function) (?:0)

platformVersion : 5.1

This is a really confusing error. .so files are Android NDK shared object library files. These are not part of the GPGS v2 plugin. It’s only .jar files.

It’s almost like where you’re some how loading the old Android GameNetworking library (before we pulled it out into a plugin). But if that were the case it would load everywhere and you would have this error all the time.

I wonder if maybe you’re hitting some rooted devices or something that’s not returning “android” as the platform and it’s trying to load the old gameNetworking for Android.

Can you get more logging on your server side that can get the platform , device name, etc.?


Do you know what phone that is? The 5.1.

app #1:

app #2:

app #3:

We are collect that data: appName, appVersionString, architectureInfo, build, model, platform, platformVersion, errorMessage, stackTrace. (by the system.getInfo )

It is version code of Android Lollipop.

Hmmm. They all share Android 5.1 and an Unknown architecture information.

Let me share this with engineering.


So, after hours of investigation, I realized that this issue is general, not specific to any native C++ plugin. It seems like Android 5 has some issue with loading native libraries. I am investigating fixes.

By the way, does anyone here actually have a device which has this issue reliably reproducing? This is Android bug when it fails to load very valid existing libraries. It would be very hard to fix, because code is correct, it just system functions fail when it shouldn’t (basically opening library fails, even if library is in place and accessible).

If anyone has a device which has error reproducible and can test APK here and there it would be amazing

We have only two test devices on 4.1 and 6.0.1 versions of Android.

I tried on 4 android 5.1/5.1.1 devices (Huawei P8 lite, OnePlus One, Nexus 6 and Galaxy J1), they seem to work fine, so no repro :frowning:

Fortunately, this is not only my issue: it seems like lots of people on internet have this, so I may have some idea how to fix it. Bad thing that I didn’t find any code which solves same issue: there are several libraries but they all solve Java related issue, not one we have in Corona ( we’re using dlopen/dlsym system calls directly from C++).

Long story short, we’re working on it. Would be easier with a way to test it.

Vlad i am looking for a phone. I went to 3 pawn shop yesterday with no luck. I also looked on Ebay (for a cheap one) and asked my Indian friends. I don’t think the phones you have you will be able to reproduce the issue. These OnePlus One, Nexus 6 and Galaxy J1 are 32bit and this one Huawei P8 lite is using a second gen 64 bit. 

Every report so far has been a first generation 64 bit phone running a processor with ARMv8-A. Most of them are running MediaTek processors. At least that is my current theory. I am probably wrong, but I suspect that those phones were working fine in 32 bit mode. Once they switched over to 64 bit they can’t load the libraries.

I also looked at a way to force 32 bit mode on a specific android version during install. Although you can do it from the command line, I didn’t find a way to do it from Google Play store.

From the reports that Gent provided:

Lenovo A7020. MediaTek ARMv8-A

Meizu M3 Note. MediaTek ARMv8-A

Cubot X17. MediaTek ARMv8-A

Xiaomi Mi 4C. Snapdragon S808. ARMv8-A

Huawei Tag-L21 MediaTek ARMv8-A

OK. Attempting to buy one of this bad boys. Shouldn’t be too hard.

OK. I have a bad news/good news situation: first, I bought Meizu M3 Note, with MT6755M and processor and android 5.1. Bad news - everything seems to be working fine if installed from the APK via ADB.

Does anyone have link to the store, so I can test their store bought APK? Also, this device doesn’t NOT come with Google Play Store. Or is this just my firmware? I’m not an Android person, how this suppose to work? Do you want to try sending me your APKs to test? You can upload them to or something and PM.


Wow Vlad you went all out with that great phone. I can’t find one yet. Did you see this link? It looks like this issue goes way back:

Or it might be the same issue.

Hi Vlad, I sent you version 223.apk in Slack on Friday September 6th. That one was downloaded from Play Store

Quick update: I bought a device and able to reproduce the crash with provided project. Will try to fix it. Also, I seem to get nasty cold, so it will delay working on it a little.

Vlad I’ll leave it in your capable hands since you are now a few steps ahead of me. I got 2 similar phones but hey had all been upgraded to newer versions of Android, i had been trying to downgrade them with no luck. Good job in finding the phone and being able to replicate it. And hope you feel better soon.

So… I tried my fix I made yesterday, and it worked. Look out for daily build in next hour or two.