GPGSv3 Snapshots

Hello there,

Apologies but 'tis me again, this time having issues with Snapshots.
I have acheivements and leaderboards working but simply cannot get snapshots on the go.
I can seemingly open a snapshot, but not read or write it’s contents (i.e. my actual game data). I have been using code examples from a few years ago but there is nothing using v3.

I repeatedly get: errors on Cloud console when attempting to use this API.

  • I’ve tried different conflictPolicy settings.
  • does nothing.
  • I’ve tried checking for errors and isClosed()
  • I’ve tried converting the contents to json.
  • I’ve tried using resolveConflict (seemingly does nothing?)

I wonder if anyone in the know could provide an example for us please? :pray:

The documentation here: Solar2D Documentation — Plugins | gpgs3 | snapshots is not self explanatory and I’m struggling to understand the workflow - following: GPGSSnapshots/scenes/menu.lua at master · coronalabs/GPGSSnapshots · GitHub has not worked for me.

A small example project using v3 would be really awesome!! :smiley:
Best wishes,