How To Enable Advertising Tracking Flag For FAN?

I just got a message in my Facebook Audience Network dashboard that I need to “set the ‘Advertising Tracking Enabled’ flag to continue effectively monetizing your iOS apps.” The page explaining it is here:


Two part question:
  1. Facebook describes this flag as, “…[allowing] you to inform Facebook whether to use the data to deliver personalized ads in line with your own legal obligations, platform terms, and commitments you’ve made to your users.” My presumption is that this flag refers to the App Privacy information that is part of the new iOS App Store “nutrition label,” and is not related to direct user opt-in as with GDPR, CCPA or NSUserTracking. Does anyone know for sure?
  2. Does anyone know how to deliver this information to Facebook? Is it part of the init? A new entry in the plist? (The directions given are for C, Swift and Unity.)

Hey! Thanks for pointing this out. I added the init table argument {advertiserTrackingEnabled = true/false} so you can set it.
See docs: https://docs.coronalabs.com/plugin/fbAudienceNetwork/init.html

I’m still getting warnings from FAN about the Advertising Tracking Flag from Facebook, which confused me until I realized- I don’t use the FAN plugin for iOS any more. Now that FAN has moved to bidding-only for iOS, I don’t think anyone does.
I guess I could include the FAN plugin just for the purpose of passing the flag, but that seems like a bit overkill just to get advertising consent info to Facebook.
@agramonte I’m using your ironSource plugin to serve FAN ads to iOS- how are you tackling this issue?

I don’t see that issue on my Facebook console? Where do you see it?

In the FAN Monetization Manager, I’m seeing it under Integration > Properties

I’m also seeing this in Integration > SDK, but it could just be from having a few people using very old versions of my app

My plugins do not have it built-in. So you have to do it manually with the ATT plugin. I do it his way when I want to show it:

if options.platform == 'ios' then
    local att = require "plugin.att"
    local function attListener(e)
        adProvider.startProvider(options)
    end
att.request(attListener)

end

My ironsource plugin you can display ironsource’s pre-message with:

 ironsource.show("consentView")

Which will show this dialog box:

You can read the documentation here:

And there are a million think pieces on the web when to show the pre-dialog box and when to show the actual dialog box.

So what I will do with the next update:

  1. Don’t ask the first time.
  2. After the first time, I provide the ironsource dialog and when they click next I present the permission dialog (when the event for button is clicked is returned).

I get ATT through other plugins in my waterfall- the problem seems to be that FAN isn’t getting the message.
Honestly though, don’t worry about it. I make so little money from FAN anymore, it’s not worth the effort.