How to fix Google play ANR stability

I try to release my game , but i found this error from google:

java.lang.IllegalStateException: This task listener doesn't support child surface attachment.

Full Error:

Exception java.lang.IllegalStateException: This task listener doesn't support child surface attachment.
  at$TaskListener.attachChildSurfaceToTask (
  at (
  at (
  at android.view.WindowlessWindowManager.addToDisplay (
  at android.view.WindowlessWindowManager.addToDisplayAsUser (
  at android.view.ViewRootImpl.setView (
  at android.view.ViewRootImpl.setView (
  at android.view.SurfaceControlViewHost.setView (
  at (
  at (
  at (
  at (
  at (
  at (
  at android.window.TaskOrganizer$1.lambda$onTaskInfoChanged$6$TaskOrganizer$1 (
  at android.window.TaskOrganizer$1$$
  at android.os.Handler.handleCallback (
  at android.os.Handler.dispatchMessage (
  at android.os.Looper.loopOnce (
  at android.os.Looper.loop (
  at (

aff :sleepy:, 1 week trying to release my Game

@vlads , how i can solve it?

We need an example or Code-Snipped and what kind of publishing do you do? Like Windows / Apps, which kind of Build-Process?

1 Like

Hello, I get the same thing on the latest daily build. Prod build to android. Google play pre launch report says that devices with the following configuration get the error:

Generic Small Desktop (x86) (virtuell)
Android 12L (SDK 32)


Otherwise it seems fine. I’ll try to exclude them from test and production to play store if possible?

Is ignoring it and publishing an option? An error that only crops up on a “Generic Small Desktop (x86) (virtual)” sounds kind of like a non-problem.

I wouldn’t mind that at all and I tried making the list of supported devices smaller but play console keep saying the app doesn’t load even though it works on my phones when I test. So I’m kinda stuck.

Is this your first time putting this app through the Play store, or is this an update? (i.e. Did it pass earlier and doesn’t pass now?)

Its an update to an old game. Previous update was in 2016 so it’s possible I’m using some old api or something too. It seems to work ok still though both on the simulator and on device.

OK- so my usual advice of rolling back to the last version of Solar2D that worked is probably not applicable here. :grin:

Do you have minSdkVersion set in the android portion of build.settings? Try adding it or setting it to "16" if it’s not already.

Probably not lol. It was still called corona last time I used it. Oh that’s a good idea! I could limit it to sdks 33+ whatever the equivalent would be.

It worked! Thank you so much :smiley:

1 Like