HTML5 Build

I have not messed with HTML5 builds … played with it a bit maybe 3 years ago - and was able to create, then build for HTML5 - and tapping the index.html opened the app fine(3 years ago) … just tried recently and continue to get ‘failed to load bin file’ I have no idea what has changed in 3 years. I have the latest build 3695 and java is 8 update 231. Xcode 13.1.

Tested creating a simple app - only shows an image on the screen, so no complicated code involved and used no plugins in build.settings

Most all the info on HTML5 I see on the forums here, are very outdated and not helping. I recall again, 3 years ago it quite simple to build the app to HTML5, just can’t figure what I may be doing different now.

I do get a black and white solar2d splash screen to appear, but not the simple app.

Can anyone point me in the right direction.

Thanks much!

For what you said you are in Mac, so I don’t know what can be different there for the HTML5 builds. I’ve made several HTML5 builds from my PC (Windows) and I’ve never got that issue.
Try using the Solar2D build 2021.3659. I don’t know why but some times my HTML5 builds had wrong behaviours with current builds, but the builds created with this one always work. Is the issue continues then you have some error in your code.

BTW, you said you open your HTML5 builds tapping the index.html and that is not the normal behaviour. You’ll need to submit your build files to a hosting in order to run your project from a browser. You can also test your build choosing the option Open in browser after creating your build.

Thank you much - I have tried ‘open in browser - safari’ on that ‘index.html’ but got same message. ‘failed to load bin file’

I create a folder ‘Test’ to save the build to
The build creates a folder in the ‘test folder’ called ‘Test HTML5.html5’
In that folder is:
** there is no .bin file in the folder

Does that seem correct from your experience?

3 years ago when I messed around with Roaming Gamers HTML5 sample he posted called. ‘001_Pig’. in the build folder there was a ‘.bin’ file
In the test build I did there is no. .bin , so I am not sure why there is no .bin file getting generated now.

I am using Safari 14.1.2 … I wonder if that is the problem, or as you say maybe I need to drop back to build 3659

Lastly, what ‘hosting’, would you suggest I could goto to test my app as I work on it?

Thanks for you kind help!

Sure, there should be a .bin file…that’s weird… let me check for my self

I’ve tried and I do get the .bin file. Note that I’m on Windows and you are on Mac. I don’t have experience creating HTML5 builds in a Mac. Maybe that’s an issue with Solar2D builds on Mac.

Thanks for your quick reply… I will keep at. And thanks for your help!

1 Like

SO … I went back to build 3659, and it works. - thanks to the great help from you!
Although - wow that is like 35 builds ago. Hopefully the next-newest build will correct what appears to be an issue with the build.

Thanks again!

Great… You should open an issue on Github related to HTML5 builds on Mac(maybe Windows too):

I’ve several games on HTML5 platform and I make all my builds with Solar2D 2021.3659, so it should not be a problem.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.