Installation of snap on Ubuntu 23.04 fails - Ideas?

Hello folks,

I am trying to install Solar2D on my Ubuntu laptop, using the snap file available on GitHub.

I have tried a couple of different builds, but I get this error message:

error: cannot find signatures with metadata for snap

Using Ubuntu’s built-in Snap store “Ubuntu Software” I was able to find an older build of Solar2D, version 2022.3684

I am either missing something, or the Snap support is broken. This probably belongs on GitHub, but I thought I would check here first. Any input is appreciated.



Command should be sudo snap install 'pathToSnapFile' --dangerous

If open the Terminal where the file is located then it would be:

sudo snap install Solar2D-Linux-2023.3696_amd64.snap --dangerous

The application itself doesn’t show proper version after installation, but you can confirm with

snap info solar2d

1 Like

Lovely, thanks! And I learned something new about Snap!

Two follow-up questions:

  • Is this documented anywhere that I could have found on my own? I am not talking about the Snap flag itself, I am talking about installation instructions for Solar2D
  • How do I get the release notes on GitHub to be fixed? Because they do not mention the flag



I don’t think it’s documented anywhere. :thinking:

In the first releases of snap it was sudo snap install solar2d --classic and eventually the classic part of dropped. I would have to double check, but I’m honestly not sure whether --dangerous is required when installing from the snap store as oppose to installing directly from a local file. If it is required then it should definitely be noted.

You can open an issue on the Github repo to be noted for the next person going through the same thing. :slight_smile:

The first thing I tried was to indeed open the file directly with the GUI and the “snap” store. That also failed. That’s when I switched to the command line to figure out what the problem was.

I will try to log the matter to GitHub, then. Or even make a merge request.


1 Like