Invalid Swift Support, Swift support folder is empty

Hi, I’ve just tried to submit an app to the App Store but it got rejected as it had ‘Invalid Swift support, Swift support folder is empty’.

I’m using Solar 3620 and Xcode 12.0.1.

Any ideas?

Many thanks

Matt

I uploaded one yesterday without any issues using version 3619. Can you try version 3619?

Hi @agramonte,

I’ve tried that but no dice. It’s asking me to rebuild the app using the current public (GM) version of Xcode and resubmit. As far as I’m aware using my version of Catalina I only have one version of Xcode available to me.

I’ve tried creating new certificates for the game but still receive the same error.

Hrm…

I just submitted a new build successfully. Build with 3620. But I haven’t updated to Xcode 12.0.1 yet, still on 12.0.

Just as a test can you try adding my Appodeal A plugin. Don’t initialize it. Just add it to your project.

1 Like

Thanks Markus, it’s possible the new version of Xcode is causing the issue.

@agramonte I removed Adapters A from the plugins and added libplugin_appodealadapters.a into the folder. I received an error from iTunes Connect, see attached image.

Thanks

Matt

can you just do it with the adapters? are you doing native builds? So here is why I ask. The reason why Appodeal would not and does not build is that there is an error with the Swift Support library. How I got appodeal to work is by creating that static library with the Swift support libraries. It has adapters in it but that is because I was lazy when making it and didn’t want to go back and remove them. In any case, I am going to download 12.1 and see what I get.

It worked without any issues. Simulator build.

Screen Shot 2020-10-01 at 7.33.53 PM

@agramonte Thanks for investigating. Looks like the issue is definitely something I’m doing incorrectly.

It’s a an old game now, first published in the Summer of 2017, but from what I can tell contains the same files as when I create a new project in Corona.

I’m building with Simulator Build and submitting with Transporter.

Excuse my naivety, what exactly happens when I add your Appodeal links to my build settings?

https://www.solar2dplugins.com/download/appodeal-274-ios-14/playhouse-games/c488d652cb929bac1f6e6347a3f8a4d82dd9fc92-iphone.tar.gz

In my plugins I have both
[“plugin.appodeal”]
and
[“plugin.appodealAdaptersA”]

Did your build succeed with both?

Many thanks

Matt

My build has both but plugin.appodeal has nothing that would impact you. AdaptersA has all the SwiftLibraries. If that works. I can create a plugin with just the swiftLibraries.

Hi @agramonte Is there any chance you could upload a screenshot of your folder structure and build settings? I think I must be doing something wrong this side.

Do I need to include any of the files from the iPhone stub?

Many thanks

Matt

I really don’t understand what you are doing. I think I misunderstanding a key point. I just add the URL that is provided by the solar 2dplugin site in my build settings.

Like this:

["plugin.appodealAdaptersB"] =
		{
			publisherId = "com.cabagomez",
			supportedPlatforms = {	
iphone = { url="https://www.solar2dplugins.com/download/appodeal-274---adapters-b/xxxxxx-iphone.tar.gz" }
} 
}

If you are doing a native build then you don’t need to bother with my plugin just:

  1. Add a swift file call it whatever you want to your project.

  2. Go to the link libraries with binary and add the swift tbds:

Screen Shot 2020-10-02 at 9.06.31 PM

Hi @agramonte I’m following your guide correctly. It’s not an Appodeal issue or your plugin, there’s something else with the game that’s causing the issue.

‘The SwiftSupport folder is empty. Rebuild your app using the current public (GM) version of Xcode and resubmit it.’

I’m looking into how else to fix, thanks for your time.

Thanks

Matt

@playhousegamesuk don’t give up on me yet. Send me your build setting. Let me see if I can figure it out.

@agramonte A welcome note! I’ve been going round in circles. I’ll message the build settings direct. Thanks.

Hello
I had the same problem
Have solved this problem by using
in build settings Appodeal, appodealAdaptersA
from https://www.solar2dplugins.com/plugins/

Xcode 12.0.1, Solar 3620