iOS 15.1 ATT new game rejection


After reviewing a new game they sent me this from Apple:

Guideline 2.1 - Information Needed

We’re looking forward to completing our review, but we need more information to continue. Your app uses the AppTrackingTransparency framework, but we are unable to locate the App Tracking Transparency permission request when reviewed on iOS 15.1.

On my tests the permission request appears but I got the 14.4 version on my devices and just started downloading 15.1.

Should @vlads upload a new Solar2d version supporting 15.1 or am I doing something wrong?

A few months ago I uploaded a new game and updated my previous with ATT and everything was fine.

Just found a possible solution on the forum and Im about to test it.

1 Like

Hi … Did you have any joy fixing this ? I have tested the fix and get authorised status on an iPhone 10 using 14.4 and a request to allow tracking on iPhone 11 using 14.8. It was rejected by apple on iOS 15 … not sure how to proceed ? will keep playing !


Have you guys looked at ?


Check this please

I did what Mediaflex suggests and at least on my devices is working fine.

Just waiting for Apple review.

Hi Thanks for the response,

I had already implemented the ATT stuff in released Version 1.1 of the app and I get tracking stuff okay and it passed apple review 8 months ago and is live and has a few thousand users currently… all good…

I updated some stuff for version 1.2 unrelated to ATT (another Game Center leaderboard and Admob instead appodeal adverts) and they failed the version 1.2 upgrade saying what I have attached below about ATT

I implemented the delay piece and I looked into this and I found that on my iPhone 11 running IOS 14.8 I received the ATT dialog successfully if the app was loaded as if this was the users first download not an upgrade from version 1.1 to 1.2. If you simulated an upgrade from 1.1 to 1.2 the app on an iPhone 11 the status was authorised and so no dialog was shown. I assume that’s the correct behaviour as you have already asked for permission in 1.1 ?. Do you have ask for permission on every version change of the same app ? And if so How do you force that dialog if it’s already authorised ?

Interestingly I tried it on an iPhone 10 using 14.4 and the status is always authorised. I assume this behaviour is correct as the ATT requirement only came in 14.5 ? so I assume thats the correct behaviour too.

I have responded to Apple showing an image of the ATT dialog but have heard nothing back at the moment.

Will keep playing but at a bit of a loss how to sort this and thoughts/support very welcomed


Sorry response to wrong post initially

Guideline 5.1.2 - Legal - Privacy - Data Use and Sharing

The app privacy information you provided in App Store Connect indicates you collect data in order to track the user, including Advertising Data. However, you do not use App Tracking Transparency to request the user’s permission before tracking their activity.

Starting with iOS 14.5, apps on the App Store need to receive the user’s permission through the AppTrackingTransparency framework before collecting data used to track them. This requirement protects the privacy of App Store users.

Next Steps

Here are two ways to resolve this issue:


  • Tracking is linking data collected from your app with third-party data for advertising purposes, or sharing the collected data with a data broker. Learn more about tracking.
  • See Frequently Asked Questions about the new requirem

Hi # AarbronSOTB

Did you pass the apple review as mine just failed again on ATT with delay and Admob ?



My game is in review but I guess it’s gonna pass.
Everything seemed ok on my device.

I use Appodeal (which integrates Admob).

The point is to ask permission before anything ad - gdpr related appears on screen.
For iOS 15 we got to trigger it using the plugin.

The moment I replied I got mail that my game was approved :smiley:

If you have the same issues as I did just keep in mind 2 things.

  1. Use the att plugin because NSUserTrackingUsageDescription in build.settings won’t trigger the permission request on iOS 15.
  2. Make sure it appears before anything ad - gdpr related.

ok thank you for the extra bit of info and congratulations for getting through review.
Do you still have the NSUserTrackingUsageDescription active ?

I will have another play… I get the ATT dialog on new installs but not on upgrades from 1.1-1.2 when I check the status under upgrade condition the ATT plugin returns authorised so no need to display *which seems correct to me" but I think Apple want it always to display. I used appodeal in version 1.1 but junked it for version 1.2 as I found it quite unstable and Admob seems more stable and consistent. We will see. I will post when I have fixed it !! if I ever do !


Is the ATT the first dialog you see ? before notifications etc


Yes I still use NSUserTrackingUsageDescription.

I don’t understand what you mean about notifications.
The ATT dialog box should appear before anything ad related screen like gdpr.

If you do that on your device you will be able to pass apple review too :smiley:

I understand, it’s frustrating, but it’s not hard to do and you will finally make it right!