Issue with Play Games Services V3 plugin

I have updated one of my apps (on 21 January) with the GPGS V3 and the login it’s working, but the leaderboards submitted don’t. I’ve attached an image showing the results on my Console. As you can see, at the end of the month the active users have increased but not the Leaderboard scores posted each day.

Are you handling the isConnected correctly? Solar2D Documentation — Plugins | gpgs3 | isConnected

Well, I think so… According to the documentation the gpgs.isConnected() return a boolean value, so my code is like the following:

if gpgs.isConnected() then
    -- Submits score to a leaderboard

Correction: I don’t use that condition to submit the scores, I just use gpgs.leaderboards.submit() without the condition. But I just tested it and I logged in ok, only the leaderboards are not being registered, and before (with version 2) it worked perfectly. Also, every time the user completes a puzzle the score is submitted on the leaderboard, so there is not enough time for the user to be logged in (which happens from the moment the game is opened).

If you see the image attached you’ll see that my users are already logged in.

Hey @Scott_Harrison
any news regarding to GPGS V3?

Sorry testing on Google Play Services difficult but I was able to submit scores. One thing I had to was update my OAuth credential use the SHA 1 provided by Play Console instead of my keystore. Go to Google Play Console/Setup/App integrity/App signing/ copy the App Signing Key Certificate SHA-1 certificate fingerprint and paste it in the Cloud Console OAuth Credential you made.

Thank you @Scott_Harrison . My scores are not working. I have a doubt: are you using the googlePlayGamesAppId parameter in your android table in build.settings?

Yes, for the record my I was still able to sign in and I got the little pop up that I was signed but I was getting network error on my leaderboards before checking my SHA1.

Nothing yet @Scott_Harrison.

I already had the SHA1 correctly. Before upgrading to V3 everything was fine: logging in, uploading scores to leaderboards, etc.

I’ve re-check my code and all is ok. The users are logged in to GPGS but their scores are not posted to Leaderboards. According to my Google dashboard was only after upate the plugin GPGS from v2 to v3 that the leaderboars posted were affectted. I have some games with Play Games Services and they were all affected after update to V3.

Well @Scott_Harrison according to the documentation, the gpgs.isConnected() return a boolean value, and also that function send a listener as a parameter that receives the isConnected event, that is a boolean value too. So, my question is, why it is neccesary to use the isConected(event.isConnected) event if the function gpgs.isConnected() return the same result?

I very recently made an update and was able to figure out a caching mechanism for isConnected and make it work close enough to the original way of returning a value. It is still not perfect( for example a player could sign out your app via the gpgs app on another device or in the background) and using the callback will give the most accurate status of the player. I just tested submitting score with v3 and seems to work okay.

So are you connected/logged to Gpgs in your app? And can you share some code on how you are submitting scores? I get that you code was working v2 and not v3 I’m trying to reproduce things on my end

You also may check if these are the same

Yes, those are the same.

I’ve printed the error that avoid my app submit the scores to leaderboards.
According to Google: A network error occurred while attempting to perform an operation that requires network access.

I don’t know why is happening this error. My app have the permission “android.permission.INTERNET”

Before change from V2 to V3 my game was sending the scores ok.

I’ve noted that the parameter googlePlayGamesAppId that is included in the android table of build.settings file doesn’t appear in the documentation for V3.

You do still need this, are you positive the you are connected/signed in? Doing some light reading online the error is also associated with a user not being sign in or connected

Ok, I’m using that parameter (googlePlayGamesAppId). I have checked it in my device and the logged in is working, but submit scores to leaderboards not.

Hi guys,

Any update on this please?
I had v2 working a year ago, for some reason it no longer is.
My attempted login is now cancelled so am looking into what’s changed Google end and if I should update to v3.
Anyone got any recommendattions/steps/tutorial on how to get this set up? Google sure as hell makes this stuff difficult for us.
Thank you,