Launchargs ios

hey everyone,
I’ve got a push notification system working and I do get launcharg keys appearing for android but
on ios its empty (empty table). This is when the app is cold-started and opened via reacting to the notificatiin, im not sure if theres something im missing:
Launchargs is read as table on start-up, also tried timer delays but to no avail

Have you completed each step from the guide? Push notifications on iOS have special requirements.

Yes I did, on ios devices i can see remote registrations occurring in the listeners and responses to notification if the app is in the background or foreground, but i still get nothing appearing in the launchArgs when reacting to a notification from a cold-start (ios only)

In my opinion this has been a bug for a while. If your app is in the background it will get the values but if it is a cold launch the values are lost. I am not aware of a way around this, but I have had it in my list of items to look at to fix.

1 Like

happy to know it’s a general ios issue (not limited to an os) cause then i don’t need to test out each one individually, let me know if it does get fixed

Yes, this has been my experience as well, for a long time. Solar2D does not cold launch from a notification while keeping launchArgs.

@vlads could something be done about this + ios foreground also not showing?

It would be essential for my business

LaunchArgs for local notification that use .scheduleNotification should now be fixed, will look into remote notification soon


cheers man

Remote messages launch args(cold) fully work now

1 Like

For both ios and android? That’s brilliant

The title and report is for iOS

1 Like

Cheers Scott, was able to successfully integrate cold launches

Yo i’ve been trying to connect with you on Linkedin but it says I need premium, is it possible to connect there?

@borismargovski connect with me?