Linux Solar2D - window size on initial launch issue

I thought I’d give Solar2D for Linux a try in a Xubuntu 18.04 VM and I’ve run into a problem.
When I initially launch the app with “” the window size is not correct and I can’t select items to get going on a project. If I move the cursor around the small window, one of the items is eventually clickable. If I then cancel opening a file or starting a new project, the app window goes to a more reasonable layout.

I can’t resize the window either. Clicking a corner or side only moves the window.

There might be a problem with the initial window size on launch. Can someone take a look at this?

Here’s what I get when I launch Solar2D:
solar linux

I loaded a new Xubuntu 18.04 VM and I still get the issue - the initial window size makes the app unusable.
Also, I tried loading Solar2D in an MX-Linux VM and I couldn’t get it to work. I wound up in library dependency hell.

What Linux distro are you using?

Hello there!

I’ve actually just fixed this issue. Rob Craig and I, are working on maintaining and improving the Linux version of Solar2D.

You can follow the project here:

We will have builds available via a deb installer soon.

1 Like