Lost Bluetooth Plugin (tech.scotth)

I am trying to install Bluetooth Plugin (tech.scotth) and cannot seem to do it.
The simulator console writes that the plugin was not found - no file ‘C: \ Users \ admin_pc \ AppData \ Roaming \ Corona Labs \ Corona Simulator \ Plugins \ plugin_bt.dll’
I will not give the rest of the console lines here, the same is there.
As I understand it, I need a file - plugin_bt.dll, or if there is more than one in the plugin, then all other files.
Where can I get these files, or where can I download them?
I reviewed the connection examples, but there is not a word where can I get the plugin itself?
Thanks to everyone who will help solve this issue!

Double checking:

  1. Are you using Solar2D and not Corona SDK.

  2. Are you following directions found on Scott’s Solar2D marketplace for his plugins?

(Found page with this google search ‘scott plugins corona solar 2d’)

Thanks for your reply!
I am using Solar2D.
Yes, it is on these pages that I found this plugin. I have two questions.

  1. Where can I get the plugin itself?
  2. Why are there such difficulties with activating the plugin and finding it - the plugin is free!
    We often use different plugins for different programs. Usually, authors post them either on their website or in the cloud storage, and anyone can simply download them without these tricky manipulations.
    All these difficulties can be tolerated with paid products when you need to sell your product.
    But in this case, I just don’t understand …

You just need to follow the instructions on the marketplace website (granted, they could be a bit clearer).

You need to create an account, then add the plugin to your plugins table in the aforementioned build.settings file and replace the “INSERT_ACCOUNT_ID_HERE” with your actual account ID. Solar2D will do the rest.

plugins = {
	["plugin.bt"] =
		supportedPlatforms = {
			android = { url="https://solar2dmarketplace.com/marketplacePlugins?ID=INSERT_ACCOUNT_ID_HERE&plugin=BluetoothPlugin_tech-scotth&type=Android"},
			iphone = { url="https://solar2dmarketplace.com/marketplacePlugins?ID=INSERT_ACCOUNT_ID_HERE&plugin=BluetoothPlugin_tech-scotth&type=iOS"},
			["mac-sim"] = { url="https://solar2dmarketplace.com/marketplacePlugins?ID=INSERT_ACCOUNT_ID_HERE&plugin=BluetoothPlugin_tech-scotth&type=MacOS" }, --Only works with Corona Simulator 3592+
			["win32-sim"] = { url="https://solar2dmarketplace.com/marketplacePlugins?ID=INSERT_ACCOUNT_ID_HERE&plugin=BluetoothPlugin_tech-scotth&type=Windows" }, --Only works with Corona Simulator 3592+

Scott is posting his plugins on his website, it’s just that you need to use Solar2D to download them instead of downloading a file directly from your browser.

The console indicates an error on line 8 of the main.lua file
Screenshots and files main.lua and build.settings are here -
The plugin_bt.dll file is not on my disk for some reason.
Tell me what am I doing wrong?

The link you shared requires access permission. You can easily upload that file to the forums instead of that.

Anyway, @Scott_Harrison might want to look at that.

Sorry, I forgot to share this folder in a hurry. Already corrected.

@Impad Have you already check out this page?

Yes. I went to your page. There are two screenshots from the link above, where you can see that I activated your plugin and inserted the account ID into the build.settings code.

By some miracle, it was possible to install the bluetooth plugin. Not the first time, but still it downloaded. Installed in the system, the application was compiled without errors, but refuses to work on a real device. I tried on an old Nexus 5 phone version Android 6.0.1
I uploaded the apk file to Google Drive and wanted to show it to the community. Then I decided to try to recompile again, and delete the first option. To my surprise, a Google disk robot showed me a window in which it was written - the file was deleted, but it remains available to the co-author … I did not have time to take a screenshot, the window hung for a few seconds, and I was not ready for this option.
As I understand it, the Solar2D development environment is free? Then my app has a co-author and he has a copy of the apk? Yes? Maybe I missed something in the license agreement on the plugin page?

From what I understand, that is a Google Drive issue. Most likely, you are sharing a folder or that specific file with someone else. Any Solar2D application does NOT have a remote co-author.

Yes, the folder in which I put the apk file was shared. The robot apparently had a glitches, but you must admit that this surprised me and alerted me.

I feel like this plugin will soon suck all my blood. Or he me, or I told him … :slight_smile: So far I can not start in any way. If someone tells me what I am doing wrong, I will be very happy.
Screenshots from phone and computer below …

To speed things up, I’d suggest posting a sample project / code here. No need for external links, you can go ahead and upload it here. It’s the 7th icon from the left in reply window, with an arrow pointing upwards. Don’t forget to remove your personal account information though.

I took this code from the author of the plugin in examples.build.settings (1.0 KB) main.lua (4.6 KB)

@bgmadclown, you could figure out why this plugin does not work for me! You never answered me. Is it my fault or not? Has this plugin ever worked for anyone before?

OK! Let’s pretend I didn’t write the last one that will be deleted in 24 hours! I had to look into that myself.

Here is how I made it work; you need to enter Account (UID) that’s at the bottom of the account page, right above Sign Out instead of Account ID.

You may want to look into that @Scott_Harrison. That case can also be true with some of the other plugins as well.

1 Like

@bgmadclown, i checked it on two phones, on both the program starts and finds other devices within sight of bluetooth. I’ll try to figure out how to use it now. Thank you for your help!

1 Like