Openssl on M1 (arm64)

Hi all,
I tried to run a simulator (2021.3663) for an app with openssl plugin in New Macbook Pro (M1 Pro) but I encountered the following error:

Error loading module 'plugin_openssl' from file '/Users/Raymond/Library/Application Support/Corona/Simulator/Plugins/plugin_openssl.dylib':

dlopen(/Users/Raymond/Library/Application Support/Corona/Simulator/Plugins/plugin_openssl.dylib, 0x0002): tried: '/Users/Raymond/Library/Application Support/Corona/Simulator/Plugins/plugin_openssl.dylib' (mach-o file, but is an incompatible architecture (have 'x86_64', need 'arm64e')), '/usr/lib/plugin_openssl.dylib' (no such file)

File: error loading module 'plugin_openssl' from file '/Users/Raymond/Library/Application Support/Corona/Simulator/Plugins/plugin_openssl.dylib'

Anyone know what can I do for this? Thanks

Yes. On fortunately it is not available (yet?). Building Solar2D OpenSSL is super tricky and honestly I gave up when ported all other plug-ins.
Probably should look into it again

Well. I can give it a try. I think I still have it running on my machine. It would be nice to get the x86 running also.

Thanks all!

TBH I still have the old MacBook Pro to build the app. But it is very inconvenient to do development when I need to switch between two computers

1 Like

I have the same error on Mac Mini M1. Please let me know if you can find a solution.