Plugins Error


I did a clean os install on my mac and now I can’t build when there is a plugin in any project.
Previously I was using CoronaSDK online builds version and just switched to Solar2D offline a few weeks ago. Everything was fine.
Maybe I’m missing something on how to configure Solar2D when you install it for the first time?

Also when there are no plugins I can build and run the app on any mobile without other problems.

I get this in Corona Simulator Console when open then project:

ERROR: Runtime error /Users/runner/work/corona/corona/platform/resources/init.lua:931: module 'plugin_gpgs_v2' not found: no field package.preload['plugin_gpgs_v2'] no file '/Users/john/Library/Application Support/Corona/Simulator/Plugins/plugin_gpgs_v2.lua' no file 'plugin_gpgs_v2.lua' no file '/Applications/Corona-3607/Corona' no file '/Users/john/Library/Application Support/Corona/Simulator/Plugins/plugin_gpgs_v2.dylib' no file './plugin_gpgs_v2.dylib' no file '/Applications/Corona-3607/Corona' stack traceback: [C]: in function 'require' /Users/runner/work/corona/corona/platform/resources/init.lua:931: in function 'require' main.lua:119: in main chunk

Some more info.

I use three plugins.
Appodeal, gpgs ver2 and pollfish.

Appodeal works fine but I have the above problem with the other two.

Even more info and solution (?)

There is not Application Support in my mac’s Library folder so I don’t get the folowing line:
/Users/john/Library/Application Support/Corona/Simulator/Plugins/

But there is Users/john/Solar2DPlugins/Caches/Solar2Directory/coronalabs/com.coronalabs
and all plugins are downloaded there!

I downloaded 3580 version for offline builds, logged in, made a successfull build of my app and 3607 started working too after that!

What is happening?
Am I missing something about how online version work?

Also installed Solar2D 3607 on pc with windows 7 (never installed any version before) and I got the same error for the same app!

@vlads any info please?

Thank you!

This is weird. May I ask to make an extended log of the build, see if anything pops up there:

 reg ADD "HKEY_CURRENT_USER\Software\Ansca Corona\Corona Simulator\Preferences" /f /v debugBuildProcess /d 5

Same error here building for Android.
On Mac, build 2020.3607 works fine (2020.3579 also installed).
On Win 8.1, with build 2020.3607 I get the same error as Conrad after trying to add gpgs.v2 plugin.

Everything fine with the other plugins I’m using (google.iap.v3,, appodeal.beta), just problems with gpgs.v2

Any ideas or something I can try?
Thank you!

Today this is working for me on Windows. Same build and same code. I was just trying and what I did was:

  • Comment my build.settings code about gpgs.v2 plugin and copy again without the “supportedPlatforms” option.

  • Move the “require( “plugin.gpgs.v2” )” to main.lua
    No runtime error now.

  • Then I changed the code to exactly how it was before. No runtime error.

Well, now it’s working but this can’t be the solution. Any ideas? @ConradH, are you still getting this error?

That’s my Corona Simulator Console log.

@vlads could you check it please?
It’s so easy to reproduce it.

Sep 08 14:08:17.126 Copyright © 2009-2020 C o r o n a L a b s I n c .
Version: 3.0.0
Build: 2020.3614
Sep 08 14:08:22.813 Copyright © 2009-2020 C o r o n a L a b s I n c .
Version: 3.0.0
Build: 2020.3614
Sep 08 14:08:22.821 Loading project from: ~/Desktop/
Sep 08 14:08:22.821 Project sandbox folder: ~/Library/Application Support/Corona Simulator/
Sep 08 14:08:22.841 Platform: iPhone / x86_64 / 10.15.6 / Intel® UHD Graphics 630 / 2.1 INTEL-14.7.8 / 2020.3614 /
Sep 08 14:10:25.305 WARNING: disabling the idle timer can reduce battery life on the device
Sep 08 14:10:25.306
Sep 08 14:10:25.310 ERROR: Runtime error
/Users/runner/work/corona/corona/platform/resources/init.lua:931: module ‘plugin_gpgs_v2’ not found:
no field package.preload[‘plugin_gpgs_v2’]
no file ‘/Users/caseyfields/Library/Application Support/Corona/Simulator/Plugins/plugin_gpgs_v2.lua’
no file ‘plugin_gpgs_v2.lua’
no file ‘/private/var/folders/nb/q2vfxk_11dd30v5zdh4_l0cc0000gn/T/AppTranslocation/FDE32637-F2D4-47D6-B2BE-8E2B7B99AB6E/d/Corona’
no file ‘/Users/caseyfields/Library/Application Support/Corona/Simulator/Plugins/plugin_gpgs_v2.dylib’
no file ‘./plugin_gpgs_v2.dylib’
no file ‘/private/var/folders/nb/q2vfxk_11dd30v5zdh4_l0cc0000gn/T/AppTranslocation/FDE32637-F2D4-47D6-B2BE-8E2B7B99AB6E/d/Corona’
stack traceback:
[C]: in function ‘require’
/Users/runner/work/corona/corona/platform/resources/init.lua:931: in function ‘require’
main.lua:119: in main chunk
Sep 08 14:10:25.310

I did the trick with an online version first and then the build was completed with 3607 too.

It failed with 3614 though.

@vlads you should spend some time on this.
Basic things don’t seem to work.
Someone who downloads Solar2D for the first time, will just delete it.
At least that’s what I would do.

Console this time with 3614 failing.

Sep 08 14:48:47.210 BUILD FAILED
/private/var/folders/nb/q2vfxk_11dd30v5zdh4_l0cc0000gn/T/AppTranslocation/450F0549-02E6-45D0-9796-A70B239E3FCC/d/Corona src ‘/private/var/folders/nb/q2vfxk_11dd30v5zdh4_l0cc0000gn/T/AppTranslocation/450F0549-02E6-45D0-9796-A70B239E3FCC/d/Corona${}/resource/’ doesn’t exist.

@diegolmozo if I understand correctly, Solar2D auto-downloads the plugins.

For some of them, like gpgs plugin, Solar2D doesn’t do that so we get errors.

Maybe version 3616 corrects that issue.