Problem with path file on Android Device - MAC M1

Hi there,
I have a problem with compiling for android device.

When I compile the apk and download it on the device no longer displays the web pages.
Strangely it displays the path of my computer and not the path documents of the device.
As if it does not recognize that it is on an android device, it takes the path of the my computer.
iOS no problem, it works.
Never happened.

Corona release 3674
NOTE: I have changed computers, I have a MAC M1 pro and I am compiling with this machine.
Could this be the problem?
Any idea?

same problem when I write the files, doesn’t take the system.path of the device but it ‘remembers’ that of the computer

My code for html page include: webView:setNativeProperty(“setAllowFileAccess”, true)

The other old releases of my app compiled with old Mac have always worked great.
All the best

My suspicion is that the latest OS update causes this.

On both Mac M1 and MAC intel (updated) the android builds, which used to work, now no longer work.
The error is on system.DocumentsDirectory (does not find the path) both to read and write files and to local html files…
Tested with last version 3674 and con old version 3666


I’m debugging: apparently no subfolders are created in the device sandbox.

I have always used the ZIP plugin: never had any problems, a zip file was correctly unpacked with its subfolders. Now it doesn’t seem to work anymore.

Are there any additional parameters to ensure that subfolders are created when expanding files in the sandbox?

Or is there an alternative to copy groups of files, including subfolders, to the sandox of the device?

My project has to copy an entire site from the resourseDirectory to the DocumentsDirectory of the device, therefore includes folders like ‘images’ ‘css’ etc.

I repeat that until now, before the S.O. update, everything worked, I’m at the 13th release on the store.

Kind regards

ok, the problem is not the operating system.
Apparently, by testing, the ZIP plugin is no longer able to create subfolders.
The fact is that the flaw occurs only on Android

I saw the ZIP plugin on GITHUB and it was updated 4 days ago.
How do I get and have Solar2D compile a previous release of this plugin?


The bug of plugin ZIP is fixed! Now all ok.
Thank you Vlad

Best Regards
Momento Medico