Problem with the language of the application in the Apple Store.

There has been no way to set the language of the application that appears in the App Store for a long time.
The language of the application appears in English in the store, but in Apple Connect it is in Spanish (Spain), I set it several times and it does not change how it looks for sale.
I consulted Apple. The answer is varied: you have to set the language to Spanish in Apple Connect. I already did that and it doesn’t work.
The other answer is: there is a preference in Xcode that allows you to set the language. I use Xcode to load the app on the device for testing, but not to compile or develop it.
And the third option that Apple gives is: it may be because you are using a third-party tool. That would mean the problem is from Corona SDK / Solar 2D.
I ask: Does this happen to some other developer or does it only happen to me? Is it Apple’s problem or not?

You just need include App Store translations for each language you support. This can be as simple as a “.lproj” directory for each language you support and a file with a localized long and short name for your app.

Here’s the info…

So to support Russian, just make a directory called “ru.lproj” and put a simple Info.plist file in there with one line…

CFBundleDisplayName = "YourAppName";

Where YourAppName is the translated name for your app. You can also localize anything else that in file you want.

More info on that is here…

That’s it!

Check out RogueJack on the appstore to see how it shows up in our listing…

Thank you. I could already fix it. The information they gave me is identical to yours. I appreciate the effort. Hugs.