Receiving Error: Licensed with new AAB for Play Asset Delivery

Hi All,

Has anyone else implemented the Play Asset Delivery successfully?

I am using Solar2D release 2021.3648 and trying to make use of the new Google Play Asset Delivery included with Solar2D release 2021.3647.

From what I read, the way to use PAD is to upload the AAB file instead of APK+OBB.

I accepted Google’s Play App Signing and uploaded the private key as they request, built and uploaded a AAB file for the first time, then released to internal testers.

I downloaded the updated app on the Play store, then received an Error: Licensed. I do see the app’s loading image, then the error appears. There is also text that reads "Press restart to download resource files 0.00/0MB.

On the GitHub page, Vlad says to still use the usesExpansionFile = true, identifier. I am wondering if this is being included in the manifest and then Google Play is looking for an OBB file still?

I am wondering if anyone else came across this. I am new to the PAD and AAB process so it is possible I missed something in the setup.


This shouldn’t happen…

Having the same issue when using AAB. I don’t understand why it’s throwing an error, shouldn’t it proceed if the app is licensed?

I’ve only tried installing the app from Google Play during the internal testing stage, could this issue only be happening during internal testing but work after a final release?

On the GitHub page, Vlad says to still use the usesExpansionFile = true, identifier. I am wondering if this is being included in the manifest and then Google Play is looking for an OBB file still?

That’s what I thought as well, I tried uploading an AAB with usesExpansionFile = false, but there were issues with the APK file size being too large embedded inside the AAB

Anyone else having similar issues?

If it does not work during the internal testing you should not push it to release for sure.
Do not upload OBB file.
I have several questions though. First, are you building from the Simulator, not using Android Studio. Second - is this behavior consistent across all the devices?
If yes, then unzip your aab file, and it should contain directory preloadedAssets with all your assets in it.

I’m using the simulator. I’ve tested it on 2 devices and both show the same error. I’ve unpacked the .aab and see the preloadedAssets directory and it contains all of the assets. I think solar2d is trying to download additional assets from Google Play after the .aab is installed like it would when using .obb files, but it’s failing since all assets are already bundled in the .aab and there’s no additional files to download.

Do not upload OBB file.

Is there a particular reason for this, besides being new apps being required to AAB in August? Google mentions that updates to existing apps that use OBB can still use the expansion files until November, so I don’t see a reason why we shouldn’t use OBB until then.

Ok… I’m investigating… Weird that I don’t get it.

I was not able to get the play asset delivery to work so I reverted to the OBB files. I found what I could on how to properly publish the play asset delivery, I could not find any detailed information on the Solar2D documentation at the time, Is that documentation still getting updated?

I kept the usesExpansionFile = true, then built as an AAB file and uploaded to the store. Testing internally and downloading to an android device, I received and error: “Licensed”

I have not tried again recently, but I will be needing to make updates so I will let you know if the same error occurs when I try again. I believe the new Play asset delivery is required now starting this month so that will mean I am not able to update my games unless I can get it to work. Thank you

Hey! It is been a while sinte this issue should have been solved. Do you have same issues with the latest version?

Hey, I just tested it on Google Play internal test program, built using Solar2D version 3657 and the app installs correctly and runs without the licensed error. Thanks Vlad!

I was able to test with release 3659 and it appears to be working perfectly. Thank you!