Solar2d/Corona Simulator is not working properly

Hello!
I just downloaded Solar2D/Corona Simulator. When I open it, the console and the Solar2D simulator but the Solar2D simulator is blank. When I make a project and see it in the simulator it is blank.
Here are some screenshots:


Thanks in advance!

Have you tried an older build?

I am using the latest version.

What version of Windows?

Windows 7 (Ultimate)

Oh quite old then. Try updating your graphic drivers, it might help.

Will try and let you know if it works

@SGS It shows my graphic drivers have no updates.

I checked with the system requirements and my laptop fits all of them.

Tell us the full specs of your laptop.

An easy way to do this is as follows:

  1. Click ‘Windows Icon’ (lower left side of screen)
  2. Type ‘run’ and press enter
  3. run the command: dxdiag.
  4. If it asks to connect to internet, click OK/Yes.
  5. Click the “Save All Information” button and save on desktop.
  6. Review the file.
  7. Delete anything you don’t want to shrare.
  8. Save the file.
  9. Attach the file here.

I am attaching a dump from my machine as an example.

I kept these sections:

  • System Information
  • Display Devices

In ‘System Information’, I deleted ‘Machine Id’

DxDiag.txt (11.2 KB)

Here it is:
DxDiag.txt (24.3 KB)
I also kept some extra information if needed.

Concerns:

  1. 2GB Memory - This doesn’t feel like enough memory to me, but MS says they only need 1GB for Win 7, leaving 1GB free for other uses so, maybe that is OK.
    Question: How much available memory does Task manager show when you run it?

  2. I don’t think your video driver is up-to-date. Your version is from 2008, but the latest version is OCT 2009. I believe the second one down on this page is for your hardware and OS combo:
    https://www.intel.com/content/www/us/en/search.html?ws=text#q=%20Intel®%20Graphics%20Media%20Accelerator%20Driver%20for%20Windows*%207&t=Downloads&layout=table

Let’s also verify you’ve got the right version of OpenGL.

  1. Download GLView from here:
    http://www.realtech-vr.com/home/glview/
    (Click blue icon on left, not red one on right)

  2. Install it and run it. May take a while to complete. Be patient.

  3. Take a screen grab of the summary.

  4. Paste the screen grab here.

If you have trouble with the screen grab, just tell us these details (my info provided for example):

OpenGL Version: 4.6 (4.6 NVIDIA 436.30)
Driver Version: Geforce Drivers 436.30) (should be same as dxdiag showed)

Tip: This tool may also help you find driver updates if you end up needing them.

PS - I just noticed. My own drivers are a little out-of-date. :slight_smile:

Here is the info:

The minimum open GL version used to be 2.1 but this may of changed as that was when I started years ago. It might be your setup is just too old or the integrated graphics chip is not supported.

I hate to say it, but I tend to agree.

Integrated graphics, especially the older Intel ones, are often problematic for games & game dev tools in general. They didn’t age well.

Are you able to run any modern games? Have you tried running other dev tools, engines, and SDKs? I’m not suggesting you leave Corona. Rather I’m trying to work out what other debug steps you’ve taken, as well as what works and doesn’t.