Targeted at least at API level 29

Today, when uploading an update of one of my apps, in the Google Play developer console I received the following warning message:

At this time, the app is targeted at API level 28. To ensure that it is based on the latest APIs optimized for security and performance, it should be targeted at least at API level 29.

Are there any SDK updates planned shortly to resolve this issue?
Regards

What version of Solar 2D did you build with?

Hello,

Same problem here. It says that we will not be able to update the apps from Agust 2020. I’m using build 2020.3600. Thank you!

A warning does not block you from doing anything guys. It is merely a suggestion.

It doesn’t seem like a suggestion at all tbf and we are getting the same warning message. August 2020 isn’t far.

Is this the warning you’re seeing?

warning

I don’t think it iss being enforced. I’ve been updating just fine and 2019 is long gone. Still, I get the concern and hope an update will come soon to upgrade us all.

If that isn’t the warning, please share a screen capture of it so we can discuss the actual verbiage.

This is the warning but I don’t remember seeing this earlier and first got the warning when I submitted an update last night. The date on the one I saw was August 2020 and it does seem form the way they’ve phrased it that it is a requirement that must be complied with starting August.

Hello guys,

Seems like this issue does need some attention or else we won’t be able to upload any new apps on Play Store from August 3 onwards. I visited their official page to get some reliable information and they’ve clearly mentioned that post 3rd August no new apps can be submitted unless the minimum target API is met. I’m pasting an excerpt from the website referring to the issue. @vlads @roaminggamer

Already testing it

2 Likes

Yes, that’s the message that appeared to me

That is not the warning. I updated one of my apps today and I have received the same warning that orangestudios:

Warnings

Your app currently targets API level 28 and must target at least API level 29 to ensure it is built on the latest APIs optimized for security and performance.

From August 2020, new apps must target at least Android 10 (API level 29).
From November 2020, app updates must target Android 10 (API level 29).

Tip: Change your app’s target API level. Learn how.

Thanks for clarifying.

The good news is it looks like @Vlad is on top of this.

You’re welcome…Hopefully it will be resolved as soon as possible.

@vlads has this issue been resolved?

It has been resolved in 2020.3607 version