TextureResourceCanvas rendering problem

Hi guys,
I have a problem with rendering TextureResourceCanvas on one of our devices.
Texture has a size of 128x128. I create a blue rect and draw it to the texture, then create a rect using that texture. (for test purposes it’s just a blue rect with 75% alpha on a green background)

This is how this rect gets shown (the distortion is not always the same, but is has the same concept):
Screenshot 2021-03-15 at 12.50.25

In the game (not the example shown above) it even happened that half the screen around the rect drawn with texture got covered with some pattern. Texture was yellow-orange, but the pattern was blue. Maybe it had something to do with the mask that I use on a group with a rect that had this texture in it. Pattern looked like this:
Screenshot 2021-03-15 at 12.52.05

Im running Solar2D 2020.3624 on this device:
Screenshot 2021-03-15 at 12.57.17

Any ideas why this is happening on this device? I tried a few other different devices, even older Mac minis and there was no problem. I’m worried that if it doesn’t work on one device it might not work on more devices in real life.

Thank you for help

This is a weird bug. Could you send a sample code please?

Sorry for the late reply because i didn’t have access to the device with the problem.
I tried the example provided in documentation and it results in just a blank blue square.

My sample code is just a simple rect:

local width = 128
local height = 128

local texture = graphics.newTexture({type = "canvas", width = width, height = height})

local rect = display.newRect(0, 0, width, height)
rect:setFillColor(0, 0, 1, 0.75)

local tex_rect = display.newImageRect(texture.filename, texture.baseDir, width, height)
tex_rect.x = display.contentCenterX
tex_rect.y = display.contentCenterY

I also noticed that if I go to one scene first and then try the sample, the sample gets bits of images from that previous scene.
Screenshot 2021-03-25 at 08.35.08

This is a problem bothering me for a long time.
The problem can be reproduced on MacBook Pro 2017 & 2018, but it’s ok on MacBook Pro 2015 & 2019.

screenshots on Macbook Pro 2015

screenshots on Macbook Pro 2018

 local tex = graphics.newTexture( { type="canvas", width=128, height=128 } )

local rect = display.newImageRect(
rect.x = display.contentCenterX
rect.y = display.contentCenterY
local circ = display.newCircle( 0, 0, 64 )
circ:setFillColor( { type="gradient", color1={0,0.2,1}, color2={0.8,0.8,0.8}, direction="down" } )
tex:draw( circ )

Screen Shot 2021-06-23 at 6.26.37 PM

This problem only appears on the simulator. If I build the code to a native osx app, the problem will not appear.

Does anyone have any idea how to fix this problem?