Tiles and Frames... confusing property names...

It is not a major issue, but it confused me the first time going thru the tutorials:

We have “tiles” and a “tileset”, but for the animation-related properties we have to specify a “frameCount” and “startFrame”, and it’s mentioned that the animation by default is “frame-based” rather than time based…and we have handlers for “enterFrame” events…

I now understand that “frameCount” and “startFrame” properties refer to tiles… but was wondering if it wouldn’t be more clear to rename them to “tileCount” and “startTile” to avoid ambiguity/confusion. (or make an alias to those alternative property names).

-Frank.
[import]uid: 8093 topic_id: 6586 reply_id: 306586[/import]

Never mind… I was just reading Corona’s spritesheet API and see that they use the same “frame*” naming convention… just have to adjust to the idea that “frames” can mean many different things :wink:

-FS. [import]uid: 8093 topic_id: 6586 reply_id: 22900[/import]

Hi Frank,

Yea with those I went with the Corona conventions however it would be perfectly possible to have an alias for startTile and tileCount if that would help? [import]uid: 5833 topic_id: 6586 reply_id: 22943[/import]

As Corona’s spritesheet-API is using the *frame* convention, it’s probably better to stick with that.

Maybe a few words added to the Lime-API doc and tutorial, like “Note that frame in this context refers to the tile in the tileset (following Corona’s API-naming convention for spritesheets)”. That could possibly help first-time Lime’ers.

No biggie - thanks, Frank. [import]uid: 8093 topic_id: 6586 reply_id: 22968[/import]

That’s a good idea. I need to go through the documentation fully to make sure I have updated everything as there are a couple of things I seem to have missed between updates. I’m hoping the offline docs will help this as they are automatically generated from code comments so then at least if I have forgotten to update some of the online docs the changes will be in the offline ones as well.

[import]uid: 5833 topic_id: 6586 reply_id: 22969[/import]