Trying to build for Android problem

Every time I run build for Android I get this error in output.

FAILURE: Build failed with an exception.
15:34:44.894  * What went wrong:
15:34:44.894  Could not initialize class org.codehaus.groovy.reflection.ReflectionCache
15:34:44.894  * Try:
15:34:44.894  Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

Anyone know what it means and how to fix?

Are you having trouble building the demo apps or just your own?

I get the same error when building the demo apps, so both.

Can you please give us all the details about your build system you can.

  • Version of Corona / Solar 2D you are using. Ex: I’m currently running Solar 2D version 2020.3598
  • Are you using the debug keystore (that comes with the Corona/Solar2D install) or are you using your own.
  • What version of jdk do you have installed. Ex: I have version 11.0.7 installed.
  • That isn’t the whole log right. Can you give us the entire log from your console (perhaps as an attachment to your post.)
  • … anything else you think might be helpful.

I had JDK 14 installed, I installed 11.0.7 and it worked. Thanks

1 Like