"unable to sign jar: no response from the Timestamping Authority."

I have an app that I haven’t built in years. I just successfully built it in the Windows simulator, but I can’t build an Android APK using my keystore or the debug keystore either. With both keystores, I get the same error:

11:50:17.634 Picked up JAVA_TOOL_OPTIONS: -Duser.language=en
11:50:17.634 jarsigner: unable to sign jar: no response from the Timestamping Authority. When connecting from behind a firewall an HTTP or HTTPS proxy may need to be specified. Supply the following options to jarsigner:
11:50:17.634 -J-Dhttp.proxyHost=<hostname>
11:50:17.634 -J-Dhttp.proxyPort=<portnumber>
11:50:17.634 or
11:50:17.634 -J-Dhttps.proxyHost=<hostname>
11:50:17.634 -J-Dhttps.proxyPort=<portnumber>

Does this mean that my firewall is blocking Solar? How can I test that?

I’ve had that issue in the past and it was due to having a poor/unstable network connection.

The command it uses is -tsa http://timestamp.digicert.com; you can try to see if you can access digicert.com from your web browser.

I don’t think the issue is related to your old project, but to remove all doubt you can create a new empty project and try to build that.

I’m able to open www.digicert.com consistently, on multiple different browsers. On the other hand, I can never open timestamp.digicert.com in a browser, but that might not be surprising; maybe it doesn’t serve a webpage, just the certificate timestamp.

It’s not my code, either; I tried to build the sample Hello World app and got the same error.

Do you know what port it tries to use? Maybe I can check if that port is open or something…

My thought on timestamp.digicert.com is the same; I don’t believe it serves a webpage.

Since it’s using HTTP it would be port 80, otherwise the secured layer port is 443 by default.

Assuming you’re on Windows, you can try using curl: curl -v http://timestamp.digicert.com, below the is the response I’m getting.

C:\Users\siu>curl -v http://timestamp.digicert.com

GET / HTTP/1.1
Host: timestamp.digicert.com
User-Agent: curl/8.0.1
Accept: /

< HTTP/1.1 404 Not Found
< Date: Sun, 22 Oct 2023 03:29:53 GMT
< Content-Length: 0
< Content-Type: text/html; charset=ISO-8859-1

It’s possible that would also work for you, in which case it’ll come down to Solar2d’s simulator process.
If it is a firewall restriction on your side then you can disable it during your test build (whether 3rd party or Windows built-in), or you can simply make an exception for anything related to Solar2d’s processes.

I do have a workaround to avoid this issue in general, it’s OK for testing but not for production.

Thank you for the curl call. I got the exact same result you did. So I am interested in the workaround you mentioned:

Basically, I used a hex editor to patch my Corona Simulator.exe and replaced the -tsa http://timestamp.digicert.com entry with empty space.

Here’s how it looks before and after (offset may vary depending on build version):

That let’s me build APKs while offline (no network connection). Granted, I already have the required Gradle files.

That is one hell of a hack, but it’s worth a try. What is a Gradle file, and do I need to get my own somewhere?

Gradle is used to make Android builds.

Solar2D will setup everything for you, but I make mention of it because at least on a fresh Solar2D installation the first Android build process requires access to Gradle files on the web and that also takes noticeably longer than subsequent Android builds.

Ideally, you would want your timestamp issue resolved. :slightly_smiling_face:
While on that journey, if what I mentioned earlier doesn’t help narrow down the problem then you can also test using a different Windows profile.

I have also seen weird network issues in the past that were resolved by resetting TCP/IP via netsh command utility; though not sure if that’s relevant nowadays on >= Windows 10.