Unable to start the daemon process.

Hi guys! Very new to solar2d and im trying to build my first ever app. Im getting the following error tho:

The signer's certificate is self-signed.
18:45:07.434  
18:45:07.434  The timestamp will expire on 2031-11-09.
18:45:07.434  Picked up JAVA_TOOL_OPTIONS: -Duser.language=en
18:45:09.138  Excluding specified files from build: 
18:45:09.138     excluding: LaunchScreen.storyboardc
18:45:09.138     excluding: Icon.png
18:45:09.138     excluding: Icon-*dpi.png
18:45:09.138     excluding: Images.xcassets
18:45:09.138  
18:45:09.138  FAILURE: Build failed with an exception.
18:45:09.138  
18:45:09.138  * What went wrong:
18:45:09.138  Unable to start the daemon process.
18:45:09.138  This problem might be caused by incorrect configuration of the daemon.
18:45:09.138  For example, an unrecognized jvm option is used.
18:45:09.138  Please refer to the User Manual chapter on the daemon at https://docs.gradle.org/6.8.3/userguide/gradle_daemon.html
18:45:09.138  Process command line: C:\Program Files (x86)\Corona Labs\Corona\jre\bin\java.exe -Xmx1280m -Dfile.encoding=windows-1252 -Duser.country=US -Duser.language=en -Duser.variant -cp C:\Users\Jo o Ferreira\.gradle\wrapper\dists\gradle-6.8.3-all\6czipnbiesy2sl92ioo8dht91\gradle-6.8.3\lib\gradle-launcher-6.8.3.jar org.gradle.launcher.daemon.bootstrap.GradleDaemon 6.8.3
18:45:09.138  Please read the following process output to find out more:
18:45:09.138  -----------------------
18:45:09.138  Error: Could not find or load main class org.gradle.launcher.daemon.bootstrap.GradleDaemon
18:45:09.138  Picked up JAVA_TOOL_OPTIONS: -Duser.language=en
18:45:09.138  
18:45:09.138  
18:45:09.138  * Try:
18:45:09.138  Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.
18:45:09.138  
18:45:09.138  * Get more help at https://help.gradle.org
18:45:09.138  Picked up JAVA_TOOL_OPTIONS: -Duser.language=en
18:45:09.282  Android build failed (1) after 2 seconds

I tried searching for more people with the same error but was unlucky to find any. Any help is appreciated!

Apparently it was a problem with my path name (C:\Users\Jo o Ferreira) having special characters. I created a new user in my Windows with no special characters and now it’s working!

2 Likes

Is there anything reasonable that could be done to prevent this issue in the future, @vlads?

Seems like having non-ascii characters in the path trips over users every now and then.

2 Likes

Just to follow up on my own thought. I guess the simplest approach to this issue would be to just check the user’s (gradle) path for non-ascii characters at the time of build.

If a quick string check finds any non-alphanumeric characters in the path, it could just output a warning or an error about it and stating that “it may be the issue.”

I agree completely I think this problem might affect the people who are even first trying solar2d like me and like @XeduR said its not even a hard error to fix I think, just giving a warning would be fine! ^^