Updating target SDK to 33 in Android builds

I have kind of a complicated problem I can’t seem to be able to solve myself. I started working on my first Solar2D game in february and tested it out on my phone back in march successfully by downloading the apk-file. Now moths later, I returned to the project attempting to release it finally on Google Play, but the Google Play Console doesn’t let me create a new internal test that I could download from the Play store and invite testers to test it out. My game is targeted to SDK 32 but it should be targeted towards SDK 33.

I noticed that the newest release of Solar2D should address the SDK 33 requirement so I tried to install it. I installed the installer, but when trying to run it nothing happens. I installed and uninstalled the installer multiple times, but the result was always the same. I’m using Windows 11, which successfully runs Solar2D version 2022.3685.

Being unable to create a new test release in Google Play and to download the new version of Solar2D, I tried if I could atleast download the newly built apk-file on my phone, but when I tried to do that, I got a notification on my phone saying “Problem parsing the package” (translated from finnish to english, so it may not be 100% the same notification that english speakers would get). My android phone is an old test phone that I bought just to test out games on android. It is running android version 11, so I don’t know if that is a problem, but atleast it used to work fine back in march.

In conclusion, I think my question is is there any other way to update target SDK to 33 without downloading the new Solar2D version, and if there isn’t, does anyone know what may cause the installer not launching on my computer.

You can keep updating your internal track or use ADB to install the APK directly to your device. The second is much easier for testing.