webView not loading websites (anymore) in macOS built

Hello all,

For some weird reason my macOS app won’t load any websites anymore (because it did before).

There is a possibility that this happened after I upgraded to Corona 2019.3565 but  I’m not sure.

Attached are two screenshots: 1) the simulator, 2) the resulting macOS app

Can someone help me out?

Kind regards,


I solved it by using version Corona- 2019.3531  as this is broken since version Corona- 2019.3535  https://developer.coronalabs.com/release/2019/3535.

Unfortunately, this is not the ideal solution because  2019.3531  targets iOS SDK 12.4.

So I am going to use two versions for builds.

Hopefully the team can solve this permanently.

2019.3555 is the version where we changed from UIWebView to WkWebView, the modern version that Apple wants everyone to use. You could test with that version and the version before it, 3552. All of these should support iOS 13.


Thanks for the reply, Rob. Though I think you are probably mixed iOS with macOS.

The 3555 change notes contains:

  iOS: migrating from UIWebView to WKWebView

The macOS webview seems to be broken and has not been solved yet. I also verified it with a new project loading a simple page.

Can you confirm?

local webView = native.newWebView( display.contentCenterX, display.contentCenterY, display.actualContentWidth, display.actualContentHeight ) webView:request("https://google.com")

So to summarize:

  1. I am using the second latest build (2019.3565) for iOS builds

  2. and build 2019.3531 for macOS builds