Build Error 1

Can anyone provide detail on what’s going on? It seems like this error occurs quite a bit, and then I get a lucky day where it works for a short time.

Very frequently I get a Build Error #1… Error Fetching Plugins error (Win10, latest builds). This occurs on a test (empty) project and on established projects that I can successfully build the day before. I go days like this, and then for about an hour on a lucky day, I can build a project.

This appears random… I make no changes to my desktop between failures. All projects fail for days, and then one day it works for every project. I am at a point where I just fire up Solar2D daily, cross my fingers, and give it a try.

I’ve tried all solutions I can find on this forum (re-install Solar2D including wiping all known traces of files/folders/registry, delete/reinstall Java… although I do not think this is necessary any more), verbose logging shows nothing but “error fetching plugins” but does not tell me which one (including test projects with no plugins). Good/Steady internet connection here as well.

Can anyone point me to a real solution? I’ve seen several “try this” posts with limited success.


Have the same issue.
Fresh Win10 64bit, latest Solar2D buld.
Happens constantly with same error.

Unfortunately, I didn’t expect a reply in this thread for a solution to this issue. I just noticed I posted the exact same thing back in July 2020, also with no known working solution. It seems it “just works” for a short time, and then there are days where it does not.

This is getting increasingly frustrating and difficult to continue to use (for me).

I don’t really remember the error code but I also face some issues from time to time. Restarting the PC solves it for me but I’m not really sure if it’s the same issue.

We are working on macs and it’s a long long time since we had that kind of problems.

Solar2D future looks bright but errors like this should be eliminated soon.

It’s crucial for the sdk to be plug n’ play.
Errors, copy / paste / delete files to make it work is a big no.
Install Solar2D, write some simple code and build for android / ios is the way to go.

Solution found! Thanks to @vlads

You need to copy mfc140u.dll file
from Corona root folder to the
Native\Corona\bin\win folder.

That is works for me.

I just tried it (Native\Corona\win\bin), and unfortunately, that did not work for me. I see that solution in another thread, and it appears to be a solution for a similar, but not identical, problem.