Can't use font in corona simulator

I cant use fonts on the simulator. Every font I downlod do not work, and I did exactly what said here: and now when I upgraded corona (from 2014.2511 to 2015.2646) it makes even more problems. before it had just shown the Default font of my computer, and now it does not show nothing or does other problems. the only font that ever worked is “Eras Light Itc”.


We have made some changes to font handling and we are updating the guide to reflect the changes.


for now I cant use any costum font?
and why “Eras Light Itc” works?

Hi @idanahal3,

The guide is now updated. If you follow these steps carefully and precisely and a custom font still doesn’t work, most likely there is a problem/issue with the actual font file (uncommon but not unheard of).


I did exactlly that and it doesn’t worked…  :frowning:

i tried 9 different fonts and non of them worked…

I installed them on my computer and restart the computer.

please help me

Are you using Windows or OSX?

Can you post code where you are trying to use the font?


Im using Windows

    highScore\_txt = display.newText("BEST: " ..loadFile("highscore"), \_W/2, \_H\*0.458, "Wekar" , 101 )     highScore\_txt:setFillColor(0, 0, 0)

And what is the File name of the font file?

Is it in the same folder with your main.lua?


Also are you getting any errors in your console log (the black and white text window that got opened behind the simulator)?


And what is the File name of the font file: Wekar.ttf (also tried with otf).

Is it in the same folder with your main.lua: Yes 

are you getting any errors in your console log: Yes, it write - “Warnning: Could not loud font Wekar. Using defult font.”

Hi @idanahal3,

Please make this into the most simple test possible without all of the variables, like this:


highScore_txt = display.newText( “TEST”, 100, 200, “Wekar”, 15 )




Still doesn’t work.

Still doesn’t work.

Please provide the answers to the questions we asked above.  Please help us help you. 

At the end of the day, you have to use the filename (match case exactly) or you have to use the Font Family Name. Double Click on the font and look for the “Font Name” at the top of the screen.

This is certainly not a Corona SDK bug. Too many people use this feature. The documentation has been updated and triple checked for accuracy.


OK I’ll trie different computer

OK I’ll trie different computer.

It’s likely not your computer either.  Please answer the questions so we can help you?  Just a reminder of the information we need:

  1. What is the file name of the font you are trying to use?

  2. What is the Font Name? (Double click on the font from Windows and get the Font Name )

  3. Is the font in the same folder as your main.lua?

  4. What messages are in your console log? (the black window with white text that opens with the simulator)

We need this information if you want us to help you.


I answered. Never mind I’ll do it again:

1. Wekar.ttf (also tried with otf).

  1. Wekar

  2. Yes 

  3. Yes, it writes - “Warnning: Could not loud font Wekar. Using defult font.”

I didn’t see the answers above.

Anyway, why don’t you try:

highScore\_txt = display.newText( "TEST", 100, 200, "Dekar", 15 )


highScore\_txt = display.newText( "TEST", 100, 200, "Wekar.ttf", 15 )


My bad. look again I have edited my reply