Can't use font in corona simulator

What did you edit?  Have you tried the two suggestions above?


The name is “Wekar” and not “Dekar”.

And yes i tried. didnt work…

Can you zip up the font and send it to us. Perhaps put it on Dropbox and post a download link?

Hi, Rob

I have the same problem with this font for example
It works good on Android, iOS, Mac OS, but not for Windows (i use Win 7). However, I can use it in other programs such as Photoshop, office etc. Only Corona simulator can’t dusplay text with this font.

btw, I print textObject.contentHeight and it is equal to 1. Also, I don’t have a warning about using Default system font in console log.


Hi @idanahal3 and @mitsik,

If a font works on all platforms (including Android) but not Windows, this may indicate that there is something wrong with the font file and Windows is failing to load it. A good way to test this theory is to double click on the font file in Windows to see if it’s able to display its glyphs in the font viewer window. If Windows can’t load/display the font, then you have no choice but to use a different font file.

To further test that you are coding this correctly in Lua, try copying one of the installed Windows fonts to your Corona project’s root directory (alongside “main.lua”). For example, a font file such as “WingDings”. The pre-installed Windows fonts are obviously guaranteed to load correctly in Windows, so if you attempt to use that font in a Corona project and it doesn’t work, then there’s something wrong with your Lua/Corona code.

Best regards,


I said that only Corona Simulator doesn’t display text with my font, other applications (Photoshop, Office Word) can display this font. It looks good in Windows Font Viewer (Control Panel -> Fonts -> double click on font).

Of course I can’t say about all fonts (only used by me), but I’ve never seen Bold fonts in Windows Simulator. I tried to load Roboto Bold and GothicBold (dropbox link in my previous post) and some other bold fonts in Corona Simulator and nothing.

I develop with Corona few years, so of course i restarted simulator after font installed, i restarted PC etc

Some my researches:

I have installed font family Raleway (]) . I have installed two fonts of this family: “Raleway” and “Raleway Bold”. I can use them in Photoshop and other text editors. But when I call this code

with searchString = “Rale” it shows in console only:

Font Name = Raleway

there is no Raleway Bold

It would be great if it is my fault, and it is easy to fix.


Hi @mitsik,

Windows doesn’t use that “family name” or “internal font name” that you’re gathering from the “native.getFontNames()” example… that’s for iOS and OS X. When you install that “Raleway” font in two varieties (normal and bold), what are the names of the actual font files?

no metter, Raleway was as an example.

I just wanted to say that this font works everywhere


it doesn’t work in (my?) Corona Simulator for (my?) Windows.

What is that a screen shot from?  It doesn’t look like the Corona simulator to me.


yes, this screenshot from Unity to show you that this font works on my PC

i’ve tried this font on another machine with Windows 8 and it works in Corona Simulator. So it doesn’t work in Corona Simulator for Windows 7.

I don’t have another Windows 7 now to make final tests and I understand that it is not very important for you - some font doesn’t work in some Windows for some user…there are too much fonts to check each

And just to confirm, you’re running the most recent version of Corona on both the Win7 and Win8 machines?

Win7 - daily build 2015.2697

Win8 - latest public release

Hi @mitsik,

Can you please install the latest public release on the Win7 machine as well? I’d like to determine if this is an issue between versions…



I installed daily build few days ago as soon as native text fields available in win simulator (many thanks for this).

So it likes I have win7 with latest public and with daily build

So you have both the latest public release and a daily build installed on the Win7 machine? That’s fine if you do. Does the font display in the public release version?

how can i switch versions on windows? i think it updates one version to another.

Font didn’t work in the public release version. It didn’t work in version before current public release too. 

Do you have Win7? if so try to install my font, please

Can you post the code you’re using (in Corona) to display the font?


local myText = display.newText( “Hello, World!”, display.contentCenterX, display.contentWidth / 4, “GothicBold”, 40 )

myText:setFillColor( 1, 110/255, 110/255 )

this code from Corona HelloWorld project.

just for information, maybe it will help

if i call this code:

local myText = display.newText( “Hello, World!”, display.contentCenterX, display.contentWidth / 4, " GothicBold123", 40 )

i have a warning: Could not load font GothicBold123. Using default font. 

Because I don’t have font with name  GothicBold123  in my system. I see text on simulator, it uses some default font.

But when I use " GothicBold" (again, font is installed and I need to display text with this font) i don’t have this warning (as I understand Simulator sees this font in system, so it loads the font?), however I don’t see text on simulator.

Can you post a screenshot of the project directory so I can see all of the files within it?


Try to write:

local myText = display.newText( “Hello, World!”, display.contentCenterX, display.contentHeight, “GothicBold”, 40 )


local myText = display.newText( “Hello, World!”, display.contentCenterX, display.contentHeight - 200, “GothicBold”, 40 )

Because: I dont know why but in one of the fonts I use I found out it is there, but mach higher on the screen. (Just in the simulator).

But still, on all of the other fonts it writes: “Warnning: Could not loud font Wekar. Using defult font.”