Latest updates

Gumbo just got a minor update:

* Objects can now be locked in position. That way you won’t accidently move them.

* Right click on the output window now lets you copy all the generated code to the clipboard. If you just want to copy parts of it you’ll still have to use cmd+c/ctrl+c. [import]uid: 13180 topic_id: 7732 reply_id: 307732[/import]

New update:

* All display objects now generate newImageRect instead of newImage.

* A side effect of that is that cropping images is now gone, and has been replaced by the function to resize your images instead. When you import images you can select if you want to resize your object to fit the image, or if you want to fit the image inside the size of the object. You can then use the resizebar to resize anytime.

* The naming convention of objects is better. You can now define your own name of an object, and all clones of that will use the same name, with the addition of a number.

* This is an idea that I got from cl-apps, that I evolved.
New object type: Code blocks! You can now add code blocks into your canvas. These will only render the code that you put into the code field. Very useful! [import]uid: 13180 topic_id: 7732 reply_id: 27979[/import]

I hope its ok if i post in here, but these latest updates are great! thank you Dr. Nerderer! [import]uid: 19620 topic_id: 7732 reply_id: 27983[/import]

I have to say Gumbo is looking really awesome! Congratulations on some very hard work.

newImageRects work perfectly, as well as oversized images for large levels.

Codeblocks are added perfectly… not a bad idea :wink:

Gumbo was a great tool to go to for bits and pieces to layout and save time but now there’s no reason why entire game levels can’t be crafted with the most intricate code and work perfectly.

Anyway, enough praise and onto a few thoughts:

The save lua file prompted me to think, would it be useful to have a toggle to export the image objects you have been using as well as the lua code as you may have been using resources from another project, just a thought.

Other than that the option to add text objects would be clever, which could just be code block ‘snippet’ with the basics of a text object filled in but gets the coordinates from the codeblocks positioning along with a variable name. Or if your feeling adventurous a full blown text adding facility would be nice.

Keep up the great work! [import]uid: 33866 topic_id: 7732 reply_id: 28001[/import]

I’ve added support for reference points. You can easily change what you want to use in a dropdown in the object properties panel. [import]uid: 13180 topic_id: 7732 reply_id: 29669[/import]

This is a fantastic tool. Very simple and yet powerful enough. I hope to donate a good amount if I earn enough money from my game.

One request though: any chance we can get a “zoom” functionality to position sprites at a pixel level.

Oh and one question: does the “Install” button install a local silverlight version or is it just some kind of shortcut? Thanks. [import]uid: 51516 topic_id: 7732 reply_id: 34802[/import]

I did som experimenting with a zoom function a while ago. Most of it worked fine, it was just that the drag didn’t work as expected. I’d have to rework some of the dragging code to make it work better while zoomed in.

The install button lets you install a local version of Gumbo to your computer. It’s still in a Silverlight sandbox, but it behaves just like any other installed application. [import]uid: 13180 topic_id: 7732 reply_id: 34822[/import]

Just wanted to chime in and let you know that im still using gumbo alot, and plan to much more. im finally to the stage of my game were i will begin putting all my efforts on level design and creation. I also would like a zoom function ( although for my needs a zoom out would be more important ) my levels are very large. Anyways just wanted to let you know i love gumbo and hope you can continue progress on it when you have time. thanks for your work [import]uid: 19620 topic_id: 7732 reply_id: 34839[/import]

It’s been a while since the last update, but now I’ve finally made some new improvements. The big feature is the snapping setting, which makes the objects snap into place every X pixels. Be sure to check it out, since I think it’s very cool! It should be useful on a lot of projects.
What’s new:
* Canvas size and screen direction/size have been moved to the new Settings window. You open it by clicking the Settings button.
* There is a new function for snapping objects every X pixels. You can find it in the Settings window.
* You can now define the image path that will be included when generating the Lua.
[import]uid: 13180 topic_id: 7732 reply_id: 50744[/import]

Awesome! exciting that you are still going with it. By the way, i have an app that i will be releasing in the next week, all the level design was done in gumbo, it was a huge help! ill let you guys know when its out. [import]uid: 19620 topic_id: 7732 reply_id: 50755[/import]

Nice updates! Great work :slight_smile:

[import]uid: 33866 topic_id: 7732 reply_id: 50786[/import]

This is fantastic! Thank a lot for that :slight_smile: [import]uid: 27699 topic_id: 7732 reply_id: 50972[/import]

Why yes thanks for the update, I use gumbo for creating all my levels also. However I kind of use it in a unconventional manner as I wrote a python parser which takes the produced lua and converts it into a lua table for use in my game. However it works great for me for a visual layout tool.

There is a bug I have been fighting with it, not horrible but annoying. For some reason the text inputs seem to loose focus not allowing me to enter or modify numbers. Clicking to something else like the browser than back again makes those fields editable again, rather odd workaround but I get by. [import]uid: 14451 topic_id: 7732 reply_id: 51047[/import]

Yes, I know about the text input bug. It seems to happen on Mac only, after opening the Save or Open dialog. Even if you click cancel you’ll get the bug. But like you said, you can switch to another application then switch back again, and it’ll work.

I can’t explain it, but I think it’s a bug in the Mac Silverlight runtime. Hopefully it should be gone in Silverlight 5, which should be released soon. [import]uid: 13180 topic_id: 7732 reply_id: 51058[/import]

Hey guys,
i finally released my game for Android devices, and there would have been no way that i could have built the levels without Gumbo, please check it out, i think you will find it interesting and fun. here is the link.

Thanks to nerderer for such a great tool! [import]uid: 19620 topic_id: 7732 reply_id: 51778[/import]

Looks like a lot of fun. Planning on releasing it for iOS? You should.

I really like the graphics style! [import]uid: 13180 topic_id: 7732 reply_id: 51786[/import]

Yea i hope too, at this point i dont want to drop the 100 bucks developer fee with apple, i want to see how it does on android then hopefully i can put it out on ios. ill let everyone know when i do for sure! [import]uid: 19620 topic_id: 7732 reply_id: 51789[/import]

I’ve just uploaded a new version with some functions that’ll make it even quicker to set up your layout:

* Added quick buttons for rotating objects 90 degrees left or right. You find the buttons at the top of the properties pane.
* If you’re cloning (‘C’ on the keyboard) an object while dragging it, the clone no longer gets focused.
* Cloned objects will now snap into place if you’ve set a value under Settings.
The last part is really the best. You can use this to drag an object around and pressing ‘C’ wherever you want to place a clone, and it’ll snap into place. Using this technique you can create tile based levels extremely fast. Try it out! [import]uid: 13180 topic_id: 7732 reply_id: 52713[/import]

for some reason I can’t see it. Tried safari, firefox and chrome, and all it shows is a loading icon which counts up to 100% and then blank screen.
Have silverlight 4 installed on Mac os
Sorry, any ideas? [import]uid: 49842 topic_id: 7732 reply_id: 52741[/import]

Hmmm… can’t explain it. Tried it with Firefox and Safari here, and it works fine.

Have you tried reinstalling Silverlight? [import]uid: 13180 topic_id: 7732 reply_id: 52744[/import]