Sublime no longer recognizes Corona Lua

I’ve been using Sublime Text 3 (unregistered) with Corona Editor for some weeks without issues, but today my lua files are not longer recognized by Sublime. I can set it back to Corona Lua in ‘View->Syntax’ and ‘View->Syntax->Open all with current extension as…’ but when saving the file it goes back to plain text, even tho at the corner right it says CoronaSDKLua.

Edit: I’m also getting this error which seems related: ‘Error loading syntax file “Package/CoronaSDK-SublimeText/CoronaSDKLua.tmLanguage”: Unable to open Package/CoronaSDK-SublimeText/CoronaSDKLua.tmLanguage’

Hi @monge.oscar! This is related to an issue with the latest Editor commit on GitHub. I published a quick fix on my GitHub. Can you try and tell me if it works for you?

(Edit: Removed instructions to avoid confusion. Please refer to the post below.)


Thanks to Vlad, the fix above is now merged to the master branch and released. Issue should be solved with that release.

(I’ll be editing the previous message to avoid confusion.)

To speed up the process, I’d suggest that:

  1. In Sublime Text choose: Tools > Command Palette… > Package Control: Remove Package and uninstall any installed version of Corona Editor
  2. Choose: Tools > Command Palette… > Package Control: Add Repository
  3. Enter
  4. Choose: Tools > Command Palette… > Package Control: Install Package
  5. Find Corona Editor - Daily Build (or, on some machines, CoronaSDK-SublimeText ) by typing in the search field, click on it to install it
  6. Restart Sublime Text or reopen any .lua files to see the new features

I just tried it and it worked, thanks a lot @bgmadclown

1 Like

Glad to hear that. Good luck with your projects! :slight_smile:

1 Like

@bgmadclown When saving the “.lua” file, the “syntax” setting is forcibly changed to “Corona Lua”.

Thanks. We’re working on the fix.
It was due to the update pushed recently.

You need Sublime Text 3 for this to work. Took me a while to figure this out :smile:
But now it works! Thank you for the fix.

1 Like

I have the same problem and this instructions don’t fix the problem.

Can you try changing to my repo to see if it works for you?

Thanks for your reply, but nothing change with your repo.

For me it works but with your repo issue backed.

1 Like

If the official build works you should definitely stick with it.

It happens again.

Talking about this, right? In which one of the previous versions was it working for you?

  1. I don’t remember which version I used.

  2. There is a problem with the latest version. And it seems to me that this was automatically updated.

  3. You are taling as if it only happens to some users. Doesn’t it happen to you?