The password for alias androiddebugkey was not valid, or the Java JDK was not found

I reported this in Case #3597, Tim had responded with some additional inquiry but I have recieved no answer yet.

Windows 7 64, Java 32, All Env. Vars set in SYSTEM and seem to be working as i can run command from a CMD prompt.

I installed Corona, all worked well, could build, etc…

Next day and ever since, more than a week, i cannot build on the PC, everything else in the simulator runs perfectly fine.

I reinstalled the 288 build, but no luck.

I bought a license subscription… no luck.

Anyone have any ideas. [import]uid: 36439 topic_id: 6814 reply_id: 306814[/import]

Did you install the OpenSLL?

Hmmmmmm… skype = anscamobile

C… [import]uid: 24 topic_id: 6814 reply_id: 23794[/import]

I do not have or use skype and did not understand your reference.

But regarding OpenSLL, yes i did install it - “Open SSL v1.0.0b” and Java afterwards.

Maybe I need to reinstall that if you think it could be a culprit or even the Java???

I did generate atleast one build on the first day which is the strange issue.

I am currently producing test builds on the Mac but really need to get this working again and have only one PC.

Thanks! [import]uid: 36439 topic_id: 6814 reply_id: 23797[/import]

Does anyone have any recommendations?

Still dealing with this one.

Thanks [import]uid: 36439 topic_id: 6814 reply_id: 24590[/import]

Well, its resolved.

I moved the debug.keystore file and the build process, correction, jarsigner did not like it.

Thanks for trying to help. [import]uid: 36439 topic_id: 6814 reply_id: 24595[/import]

Hi, I’m trying to build an android application from Windows for the first time, and I can not build. I get the following error:

The password for alias androiddebugkey was not valid, or the Java JDK was not found

I’ve checked all the steps, and they all seem right: I have the Java SDK, the JAVA_HOME variable, and the PATH pointing to the previous one… I am using the androiddebugkey you provided, with password android…

I really don’t know what I’m doing wrong…

Thanks and regards

[import]uid: 42932 topic_id: 6814 reply_id: 26719[/import]

Make sure to keep your debug keystore in:

“Ansca\Corona Simulator\Resources” folder [import]uid: 36439 topic_id: 6814 reply_id: 26838[/import]

Is it not the same to have it in C:\Corona SDK\Resources? I’ll try…
By the way, is like this that you have solved it?

Thanks and regards [import]uid: 42932 topic_id: 6814 reply_id: 26886[/import]

The keystore must be installed in the default directory… Thanks for the hint…

Best regards
[import]uid: 42932 topic_id: 6814 reply_id: 26890[/import]

I’m having the same problem after the upgrade to CS 2011.484 (windows).

Builds worked fine before.

my keys file is in C:\Program Files (x86)\Ansca\Corona SDK\Resources.

I’ve reloaded java, and corona several times, and I do have opensll.

When I attempt to build using the android password I am otified that “the password for alias % was not valid, or java jdk was not found”.

I click ok and prompted to enter the password once again with the same message and same prompt.

My environment variables set for java are:

.;C:\Program Files (x86)\Java\jre6\lib\ext\ - CLASSPATH

C:\Program Files (x86)\Java\jdk1.6.0_24 - JAVA_HOME

C:\Program Files (x86)\Java\jre6\lib\ext\ - QTJAVA

I did delete the debug.keystore file, then relaunched corona. It rebuilt it again. didn’t solve the problem.
Any suggestions. [import]uid: 31039 topic_id: 6814 reply_id: 32736[/import]

Hello Frank,

We’re not able to reproduce your password failure issue with the debug keystore. This message is normally displayed for user’s that are using their own keystore with the wrong password. I’m assuming that you are using the “debug.keystore” that has come with the trial version.

When such a failure occurs, an error message should be logged to the console window (aka: DOS box), which reads “Corona Simulator.exe” on the window’s title bar. Can you give us that error message please?

Also, please verify that your “Build for Android” window’s Keystore field is set to the following file and path (assuming that you’ve installed the Corona SDK to the default directory)…
“C:\Program Files (x86)\Ansca\Corona SDK\Resources\debug.keystore”
[import]uid: 32256 topic_id: 6814 reply_id: 32997[/import]


Thanks for your quick response.

  1. you are correct that I am using the trial version debug.keystore, password ‘android’. have never used anything else.
  2. the console windows reports: jarsigner returned: 1
  3. the build for window keystore path is greyed out but I can see that it is set to at least down to the resource folder. browse function does not let me change this.
  4. I have installed Corona to the default path as you mentioned. The debug.keystore file is at this location.
    [import]uid: 31039 topic_id: 6814 reply_id: 33260[/import]

Hello Frannk,

I suspect that there is a version mismatch between your JDK (Java Development Kit) and your JRE (Java Runtime Environment) installed on your computer. Can you tell me the versions of your JDK and JRE please? That should help us to identify the issue and recommend a solution.

Please do the following:

  1. Go to your Windows Control Panel.
  2. Click the “Uninstall a program” link. (Assuming that you’re using Windows 7/Vista)
  3. A list of all installed programs should be displayed.
  4. Find items in this list that start with the word “Java”.
  5. Please give us a list of all “Java” items installed exactly as they appear in this list, including version numbers.

For example:

  • Java™ 6 Update 24
  • Java™ SE Development Kit 6 Update 24

Thank your for your patients.
[import]uid: 32256 topic_id: 6814 reply_id: 33280[/import]

I have the following:

Java™ 6 Update 24
Java™ 6 Update 24 (64 bit)
Java™ SE Development Kit 6 Update 24

I uninstalled the java 64 bit version and relaunched Corona. It did not fix the problem. [import]uid: 31039 topic_id: 6814 reply_id: 33295[/import]

Hello Frank,

Can you tell me what your system’s PATH environment variable is set to please?

The major Java change that was made in Corona SDK build 484 is that the software no longer requires that you set the JAVA_HOME and PATH environment variables. The new version fetches the JDK path via the registry instead.

That said, when the software looks for Java tools such as the jarsigner.exe, it will search for such tools based on the system’s PATH environment variable “first” before using the JDK path found in the registry. So, perhaps your PATH environment variable is referencing old versions of Java tools.

Perhaps a quick test that you can do is to set the JDK’s “bin” path to the front of the PATH environment variable’s string. For example:
PATH=“c:\Program Files (x86)\java\jdk1.6.0_24\bin;…”
[import]uid: 32256 topic_id: 6814 reply_id: 33304[/import]

I changed it per your suggestion and is now:

system path = C:\Program Files (x86)\Java\jdk1.6.0_24;%CommonProgramFiles%\Microsoft Shared\Windows Live;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;C:\Program Files (x86)\Common Files\Autodesk Shared;C:\Program Files\Common Files\Autodesk Shared;C:\Program Files (x86)\Common Files\Adobe\AGL;C:\Program Files (x86)\Calibre2;C:\Program Files (x86)\Autodesk\Backburner;%SYSTEMROOT%\System32\WindowsPowerShell\v1.0;C:\Program Files (x86)\QuickTime\QTSystem;%JAVA_HOME%\bin

I also have the following SYSTEM var set:

CLASSPATH = .;C:\Program Files (x86)\Java\jre6\lib\ext\
JAVA_HOME = C:\Program Files (x86)\Java\jdk1.6.0_24
QTJAVA = C:\Program Files (x86)\Java\jre6\lib\ext\

USER VAR set as:
CLASSPATH = .;C:\Program Files (x86)\Java\jre6\lib\ext\
JAVA_HOME = C:\Program Files (x86)\Java\jdk1.6.0_24

Path = %CommonProgramFiles%\Microsoft Shared\Windows Live;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;C:\Program Files (x86)\Common Files\Autodesk Shared;C:\Program Files\Common Files\Autodesk Shared;C:\Program Files (x86)\Common Files\Adobe\AGL;C:\Program Files (x86)\Calibre2;C:\Program Files (x86)\Autodesk\Backburner;%SYSTEMROOT%\System32\WindowsPowerShell\v1.0;C:\Program Files (x86)\QuickTime\QTSystem;%JAVA_HOME%\bin

[import]uid: 31039 topic_id: 6814 reply_id: 33312[/import]

and it still does not work? [import]uid: 24 topic_id: 6814 reply_id: 33313[/import]


That’s correct.

I’m really puzzled.

I’m going to deauthorize Corona on the problem machine, then reauthorize it on another. Maybe I can compare the two to find out what is going on.

Thanks for your help.

Frank [import]uid: 31039 topic_id: 6814 reply_id: 33322[/import]


It looks like it was a corrupt or damaged microsoft .net framework function.

Thank you guys for all your help and quick response.

Frank [import]uid: 31039 topic_id: 6814 reply_id: 33487[/import]

Frank, we’re happy to help and glad it’s now working for you! Have fun using the SDK. [import]uid: 32256 topic_id: 6814 reply_id: 33497[/import]